Welcome! Log In Create A New Profile


rambo board problems

Posted by romon 
rambo board problems
January 03, 2018 02:57PM
I have a prusa i3 home built printer that I had working with a ramp's mega combo controller board. Ive switched it over to a Rambo mini board, and have everything working? , but when I try to move the X or Y axis + or - both axis move. Also when I try to home X or Y both move at the same time and the Z axis move's up sharply and stop's and the stepper motor whine's loudly. I believe that I have all the wiring correct. All the end stop's are on the min connector's and show correct triggering with the M119 command. And all the settings in Marlin seem to be correct. Did I miss something or do I have a bad rambo board?

Home built prusa i3
Marlin firmware

Any ideal's ?


And yes Ive searched the form's and every place else I can think of and can't find a solution.
Re: rambo board problems
January 03, 2018 09:34PM
make sure you haven't enabled corexy or delta mode, as that ties axis together

And of course motherboard need to be MINIRAMBO and you need the rambo arduino plugins installed [reprap.org]
Re: rambo board problems
January 04, 2018 03:31PM
OK look's like I had core xy enabled. I misunderstood this setting I thought that one of them had to be enabled for the printer to work. Need to do some reading on core type's. Everything seam's to be working now, so on to calibration and the some fine tuning.

So thank you Dust for the help.
Sorry, only registered users may post in this forum.

Click here to login