Welcome! Log In Create A New Profile

Advanced

Homing the Z Axis causes a hard reset

Posted by TDecker 
Homing the Z Axis causes a hard reset
October 03, 2017 09:29AM
I have a I2C Viki LCD/Encoder connected to a Megatronics 2 board on my Glacier Summit. I am running the latest release of Marlin. As configured, the display and the encoder work as they should. However, if I try to home the Z axis either via the Viki controller OR Repetier, the printer will start to home for maybe 5mm and then the megatronics board will reset. I've tried disabling the Viki via the firmware (by commenting it out) which does allow the Z axis to home properly. I've also tried it with the Viki enabled in firmware but physically disconnected, and homing works. Is there something in the firmware settings I'm missing (the x and y axis homing works) or is there something possibly wrong with the Viki controller?
Thanks for any insight!
VDX
Re: Homing the Z Axis causes a hard reset
October 03, 2017 03:27PM
... check the correct orientation of the homing switch - if plugged wrong, it will short 5V to GND and mostly kill the voltage regulator ...


Viktor
Re: Homing the Z Axis causes a hard reset
October 04, 2017 06:42AM
Viktor,
I doubt the limit switch is to blame. The hard reset happens well before the carriage gets anywhere near the limit switch. (Additionally, the limit switches (and their harnesses) haven't been touched since I got the machine 4 years ago.) For instance, the carriage can be at 300mm (if I've just swapped out nozzles), and if I home (with the display enabled) the Z axis, the carriage will lower about 5mm to 295mm and then the board will reset.
But thank you for the suggestion.
Tristan
VDX
Re: Homing the Z Axis causes a hard reset
October 04, 2017 11:03AM
... measure the stability of the +5V (or +3,3V) level - if it's dropping below a threshold level (maybe caused by the LCD or other high load), it will perform a "brown-out"-reset too ...


Viktor
Sorry, only registered users may post in this forum.

Click here to login