Welcome! Log In Create A New Profile

Advanced

RUMBA board or Smart Controller LCD 'idiosyncrasy?"

Posted by TJM3D 
RUMBA board or Smart Controller LCD 'idiosyncrasy?"
September 02, 2017 08:56AM
I think this is the correct forum. Move it if necessary, please.

I have this RUMBA board connected and operating the steppers with 8825 drivers and it appears to be working almost normally but let me describe the problem. First, Zaxis is a 23, Xaxis is one 17 and the Yaxis is two 17s wired in series.

I found that when operating the steppers with the Smart Control panel only the Y axis occasionally moves in two segments. In other words, if I move the Y steppers (and this happens when I operate them one at a time or connected in series) lets say 10mm, most of the time I get one continuous 10mm movement but occasionally I get two 5mm movements with a lag of probably less than 100ms between the 'half' moves. On the other hand, if I make the move with the board connected to Repetier Host then the moves are perfect and never do the two part move thing. I'm assuming that it's only a direct control from the panel problem and won't be passed through to the print code (but I don't know this for sure, yet.)

What I'd like to know is whether this is a normal behavior using the Smart Control panel and also if there are some settings in the code for this particular panel that can be adjusted to eliminate this type of stepper action. I don't think this is gonna affect the prints but I won't know this until I get the entire unit assembled to that point.

Thanks,
TJM

Edited 1 time(s). Last edit at 09/02/2017 08:57AM by TJM3D.
Re: RUMBA board or Smart Controller LCD 'idiosyncrasy?"
September 03, 2017 12:18AM
I can't help, but I had similar problems with a 2004 LCD. I couldn't use USB and LCD at the same time. Like they were on the same port...
Now I use OctoPi on a RasPi to control the Rumba remotely.
Re: RUMBA board or Smart Controller LCD 'idiosyncrasy?"
September 03, 2017 07:33PM
Thanks.
Only does it when using the LCD input for movement. If I connect and use Repetier for manual control or feed some G-code for movement all three axis move without the short delay.
Did a dry run of a small part (there's no extruders in the printer yet) and the movement appeared normal and smooth. It'll be a week or so before a real test can be run.

tjm
Re: RUMBA board or Smart Controller LCD 'idiosyncrasy?"
September 04, 2017 12:47AM
There's also a chance that the encoder sends erratic signals, but that's nothing to worry about.
Sorry, only registered users may post in this forum.

Click here to login