Welcome! Log In Create A New Profile

Advanced

Z max endstop issues

Posted by bread_bird 
Z max endstop issues
June 12, 2017 04:15PM
I have a Z max endstop set up on my printer. The entire homing routine works fine, but when I check what the printer thinks its Z position is afterwards, it says 300mm. From what I have read, shouldn't the printer assume it is at Z_MAX_LENGTH after it hits the endstop? I have this value set to 95 - nowhere near 300.
I am using Repetier Firmware and a RADDS board.
Re: Z max endstop issues
June 12, 2017 10:50PM
I don't know Repetier, but I'd look for manual_home_position_z to adjust the height or use G92 Z95.0 right after homing in the startcode.
Re: Z max endstop issues
June 13, 2017 06:19PM
Yeah I already have the start gcode set up. It seems like kind of a hack though and it would be nice to be able to tell the printer to go to Z=0 before or after prints.
I don't see manual_home_position_z anywhere in configuration.h for Repetier, unfortunately. I would switch to Marlin but it's not very reliable on RADDS.
Re: Z max endstop issues
June 18, 2017 08:19AM
check what zmax length is set too in the eeprom
allso repetier host(if your using it) has a zmax setting in the printer config
Re: Z max endstop issues
June 18, 2017 11:55AM
Z_MAX_LENGTH is set to 95.
I'm not using Repetier-Host, but I didn't think that a Z max endstop could only be used with certain hosts.
Sorry, only registered users may post in this forum.

Click here to login