Welcome! Log In Create A New Profile

Advanced

Controller LCD contrast issue

Posted by drhender 
Re: Controller LCD contrast issue
May 01, 2016 08:22AM
I tried 220 ohm, 330 ohm, 440 ohm and 560 ohm. 440 ohm worked for me. Mine brand is bigtree-tech.




Re: Controller LCD contrast issue
June 11, 2016 12:18AM
Hi,

I buy the same kit : ramps 1.4 + RepRapdiscount full graphic display, and after televersing marlin, the screen lights up but nothing appear on it.
It try a 220 and 440 between pin 2 and 3, but nothing change.

What Am I doing wrong ?

Thanks
Re: Controller LCD contrast issue
August 29, 2016 04:29AM
Hi,

Just a note for those who happen to find this very useful post: it helped me rescue a defective LCD screen too.
A 560 ohm resistor between pins 2 and 3, as explained in the other posts, and the contrast is back.

Many thanks to those who found this trick winking smiley
Re: Controller LCD contrast issue
October 21, 2016 06:04PM
Thank you to the contributors of this thread, you saved me a lot of frustration after my first display appeared to have slowly "died" over the first 18 months of use of my home built Prusa i3. as soon as I installed a new display it was giving me the same contrast issue the 18 month old display had eroded to. After reading the posts in this thread, I tried 440 Ohms, and settled on 660 Ohms (because I am a registered nurse and not a real electronics guy I have limited resistors lying around). Thanks again guys!

Re: Controller LCD contrast issue
October 31, 2016 05:42AM
Hi everybody

I have some other problem. Maybe it is connected with contrast (and maybe not)
The issue is: the picture on the screen (Graphic controller 12864) is negative.
All parts that should be white are black and vice versa.
Trimpot adjusts the contrast but picture is quite pale (withered).
Anybody had such a problem?

Thank you/
Re: Controller LCD contrast issue
December 07, 2016 06:35AM
Quote
enif
I had a similar issue with my full graphic LCD controller, but I could not even see anything from any angle. I resolved the problem by adding a 270R resistor from the contrast signal (trimpot) to the 5V line. I connected the resistor between second and third of the empty pin holes as shown on the photo.
See and THIS is why I love internet.

Thanks, man! You've just saved me a month of waiting for a replacement LCD smiling smiley
Re: Controller LCD contrast issue
January 01, 2017 03:51PM
Just an update to this, I got my full graphics LCD out of a drawer and where the trim pot on the front used to do something it does nothing now.

So I bent the display module forwards to gain access to the pot on the display module itself and adjusted it with tweezers. Now it works fine.

Mine is a bigtreetech one.

Thanks for making us aware of this hidden adjustment.


[www.precisionpiezo.co.uk] - Piezo Z-Probe kits (and ready made modules)

DemonDeltaMicro - Micro Delta Printer [www.thingiverse.com]
Things I've made/remixed.
Re: Controller LCD contrast issue/ flashing and bleeping
February 19, 2017 02:31PM
Hi Guys

I have also bought this RepRapDiscount full graphic smart controller today after I had to upgrade my Anet A8 V1.0 card to a MKS gen V1.4 as I managed to brick the Anet trying to upgrade eye rolling smiley

So the MKS gen V1.4 works apart from the old LCD wouldn't. Hence buying the 12864 LCD & despite hunting the forums on and off all day, loading and reloading different files, still it still would only flash and bleep.

That is until I came here and noticed quite by chance two different pictures of the two 10 pin EXP1 & EXP 2. " drhender " Pic has both open at the bottom,while further down, " enif "pic shows both at the top.

Mine were both at the bottom and a quick snip on both pcb connectors, EXP1 & EXP2 on my RepRap 12864 LCD to open them up to allow the plugs to 180 degree into them solved my problem.

It now works fine and I hope some one else manages to find this solution too thumbs up

Good Luck & Happy Printing
Re: Controller LCD contrast issue
April 22, 2017 06:32PM
Hey there ,
Iam doing 3d printer as my project I did all mechanical work(frame x y and z axis)
But when I checked that axis after connecting with ramps it has some issues
1st issue is when I plug in usb with out connecting power supply lcd display works fine but
When I connect power supply a white screen cover the display screen .
2nd issue is I bought some motors from eBay and some from other site .The motors which I bought from eBay rotates during no load condition but when I connect threaded rod not even z axis rotates .and the motor which I bought from other site is not at all rotating its just vibrating will the problem I tried adjusting potentiometer still same vibration can anyone help me to sort this problem please
Re: Controller LCD contrast issue
April 22, 2017 11:49PM
For someone being able to help you, you need to provide more specific information on the hardware/firmware/software setup you are using.

Which controller?
Which firmware on it?
What LCD display?
Have you checked the voltage on the 5V rail? Any change when switching from USB to power supply?
Which speed and accelleration settings for motors? Have you tried lowering speed and/or acceleration values?
Re: Controller LCD contrast issue
May 10, 2017 06:37PM
270r will help you with it
Re: Controller LCD contrast issue
June 21, 2017 06:18AM
Hi all,
Here my experience with Full Graphic Smart Controller contrast issue. Same issue as many of us, so I investigate and discovered a mistake of PCB traces.
My mod needs a cutting of two traces and a soldering of two pieces of wire. In this way the original contrast pot became again operating.
Look at the attached picture.
1) Cut the traces (in Yellow)
2) Solder one wire from +5V to the pot (RED)
3) Solder one wire from pot wiper to the LCD contrast input (WHITE)
3) Switch all on and recalibrate the contrast with the pot.
Enjoy
Bye
Carlo
Attachments:
open | download - Graphic_LCD_modify.jpg (485.1 KB)
Sorry, only registered users may post in this forum.

Click here to login