Welcome! Log In Create A New Profile

Advanced

Steppers just stop - something tripped?

Posted by Zebethyal 
Steppers just stop - something tripped?
March 12, 2012 05:58AM
I am testing out my sanguinololu board (running sprinter) with some stepstick drivers I purchased from ebay.

I am using a 19V 3.5A PC power brick for power.

The seller, snipermand, sells complete and bare board versions (bareboard ones have a parts list associated with them) these boards use the 24 pin tssop version of the Allegro A4984 chip that would appear to have all of the same protection features as the A4988, but has been assembled with the same sense resistors as a pololu (0.05 ohm), so the same current calculations are valid - ItripMax=Vref/(8xRs), so for Vref of 0.4V, trip current will be 1A.

Initially when I set one of these up on a breadboard, it just sat there and vibrated, took me a while to work out how to check Vref, etc, during which time I adjusted the wiper until it locked the motor shaft and quitened down, never been able to measure current across the coils, my auto-ranging multimeter shows 0.

I have tried setting Vref to 1.6, 1.2, etc, these still caused the motor to vibrate when attached to the sanguinololu board and stepped via Printrun.

I have since set the current via the above method to 1A and lower - motor is silent and willing to step, driver occasionally gets warm, but regardless of the current setting, the motor will work for X+1 a few times, X+10 a few times, X+100, about 1.5 times and then just stops!

If I disconnect power for a while and then reconnect and test at a different setting for Vref, the same happens again.

I have tried Vref settings all the way down to 0.2V and still having the same results, works for a few movements and then no buttons do anything.

Anyone have any ideas?

I have another driver that I think has simply died - all of the others show 19V on each motor coil pin, this one shows 10V on one coil and 0.5V on the other, based on the thermal cutout and other protection features of this driver, all other pins read the same as a good driver, Vref still provides a tuneable value, etc. I even checked resistance across all of the components (voltage off) and they all have similar values to a good driver - any ideas what could have happened to this one?
Re: Steppers just stop - something tripped?
March 12, 2012 06:59AM
You can't measure current "across" anything, only voltage. Current flows through conductors so you have to break the circuit and insert the meter in series to measure current. If you put a current meter across two points it will short them together and possibly damage things.

A digital multimeter, especially auto ranging, is likely to be very confused by high speed switching signals so I would not recommend trying to measure voltage or current on the outputs. Simply setting VREF to the correct value should be sufficient.

Do the motors work when not coupled to the load? They should spin with very little current all the way up to 1A, which is the max with stepsticks. Normally the symptom of too much current is the driver gets too hot and shuts down for a while, but that should not be possible with a stepstick as current is limited. The drivers are constant off time with a minimum on time, so with a low inductance motor and a high supply voltage it could be the case that the current control does not work properly. I would be surprised if that was your problem though.

Too much current shouldn't make the motor vibrate. Are you saying they vibrate when they are stationary? When they stop are they still energised? Do the chips get too hot to touch? Is the regulator on the Sanguinololu getting too hot perhaps and shutting down the board?


[www.hydraraptor.blogspot.com]
Re: Steppers just stop - something tripped?
March 12, 2012 07:34AM
Many thanks for your reply.

You are of course correct with regards measuring current - duh should have known better smiling smiley misinterpreting the diagram on the reprap wiki with regards checking current and not actually thinking! It does indeed show the current being measured in line - could well be how the one board was damaged.

The motor was vibrating whilst stationary when everything was connected to the breadboard, likewise with initial connections to the sanguinololu, until I adjusted the voltage, it would also vibrate if I turned the shaft by hand - shaft was not locked.

Currently the motor is silent when connected to the sanguinololu, and is nearly silent in motion (about 0.5A at present), regulator chip is hot to the touch, but not hot enough to burn, the heatsink on stepper driver is also hot, but again I can comfortably keep my finger on the heatsink.

When the motor stops, it is no longer energised, shaft can easily be turned with minimal resistance, board still responds to Printrun after motor stops "ok T:0 B:0" output scrolls up the screen.

There is no load on the motor, it is just sat on the desk.
Re: Steppers just stop - something tripped?
March 12, 2012 07:40AM
Slight update - just tested again after taking the current back to 1A

motor still stops after about X+180, but is still energised - shaft is locked.

regulator is hot, can hold my finger against it for about 5 seconds, about the same for the heatsink on the driver
VDX
Re: Steppers just stop - something tripped?
March 12, 2012 07:48AM
... could be there is soft-limit activated, so the firmware won't allow positioning motors below 0 or higher 180mm.

Check in the preferences ... AFAIK in my early tests I've deactivated soft-limit to drive negative coordinates ...


Viktor
Re: Steppers just stop - something tripped?
March 12, 2012 07:49AM
Additional update.

I can do X+100, twice, then motor stops.

only X button that then has an effect is HomeX, which moves slightly in the same direction, I can then run X+100 again

at no point do any of the X- buttons have any effect.

I have tried changing the wiring on one of the coils - no difference

Same situation if I use the Y driver and a different stepper
Re: Steppers just stop - something tripped?
March 12, 2012 08:25AM
Looks like your endstops are not working so you cannot move in the negative direction because it thinks the endstop is triggered. I think the positive motion is limit by a soft limit in the firmware as Viktor suggested.

The section in the wiki that describes measuring the current with a breadboard is crazy. I think I will remove it.


[www.hydraraptor.blogspot.com]
VDX
Re: Steppers just stop - something tripped?
March 12, 2012 08:25AM
... another typical problem are the end-/reference-switches - if they're triggered, you can move only in one direction.

With:
"... only X button that then has an effect is HomeX, which moves slightly in the same direction, I can then run X+100 again ..."
you seem to have triggered endswitches.

Install/check them or deactivate or invert them in the firmware ...


Viktor
Re: Steppers just stop - something tripped?
March 12, 2012 08:37AM
That seemed to do the trick - I had no endstops attached and it seemed to think it had been triggered.

shorting the X endstop (pretending it is a normally closed microswitch) now allows much more movement X- now works as well

many thanks
Sorry, only registered users may post in this forum.

Click here to login