Welcome! Log In Create A New Profile

Advanced

Problema Homing Eje Z

Posted by rama007 
Problema Homing Eje Z
June 21, 2013 05:17PM
Buenos dias gente, tengo un problema que no puedo solucionar y me esta volviendo loco...

Cuando hago homing global (o invidual) pasa lo siguiente:

Eje X: toca el endstop, se separa y vuelve a apretar el Endstop (queda apretándolo)
Eje Y: toca el endstop, se separa y vuelve a apretar el Endstop (queda apretándolo)
Eje Z: toca el endstop y se separa (No vuelve a tocarlo otra vez, ni queda apretándolo, osea en 0) <--- Problema!!!

Eso hace que cada vez que la maquina hace un global home para empezar a imprimir, el eje z al no volver a 0 queda separado, y cuando se traslada al centro de la hotbed empieza a imprimir en el aire...

Alguien sabe como eliminar esa doble comprobación o alguna otra solución, para que todos queden apretando el endstop???

Es una Mendel i2 con Marlin con un Ramps 1.4

desde ya muchas Gracias!
Re: Problema Homing Eje Z
June 24, 2013 02:28AM
El comportamiento del homing es como tu describes pero una vez toca por primera vez el final de carrera, vueve incrementar un poco (hacia el más) y luego vuelve a decrementar lentamente(hacia el -) ... lo explico así para que sirva para todos los ejes.

Supongo que este es tu comportamiento para todos los ejes menos para el Z, que una vez llega al final de carrera, se para y no vuelve a subir y bajar lentamente ...

Quizás y solo quizás es que se muera ... prueba a darle un poco más de potencia a ver si funciona.

De todos modos, prueba los finales de carrera, con la orden M119 y los pulsas manualmente, a ver si funcionan con normalidad.

Saludos
Re: Problema Homing Eje Z
June 24, 2013 07:52AM
Gracias por la respuesta...

Te cuento el avance que tuve hasta la fecha...

Si hago un home al Z hace lo siguiente: Toca (frena) y vuelve a elevarse (no baja y queda tocando como los demas), peeeero, si vuelvo a apretar home apenas termino el otro home, toca, sube y vuelve a bajar lentamente hasta quedar en 0....

Por lo que para imprimir, previamente tengo que hacer un home, asi cuando la "impresion" hace tambien su "home previo", arranca desde 0... No entiendo pq pasa esto...

La "doble" comprobación del home es lo que me esta complicando... hay alguna manera de deshabilitarla en Arduino???

gracias
saludos
Ramiro.
Re: Problema Homing Eje Z
July 01, 2013 02:07AM
Hola Ramiro,

Perdona por la tardanza ... el home es algo de software, del programa que llamamos firmware (Sprinter, Marlin ...) no se puede quitar (a no ser que elimines el código), de todas maneras el comportamiento que comentas del eje Z es anómalo ¿por qué para? ¿notas que los motores continuan en marcha aunque no se mueva? ... quizás la conexión no sea del todo correcta ... yo personalmente intentaría cablear de nuevo el final de carrera, cambiar el conector en la placa (para esto deberías modificar el firmware indicando los nuevos pines del final de carrera).

¿Por casualidad el cable de final de carrera no 'discurrirá' junto a cables de los motores u otros cables? Si fuera así podría estar creando "interferencias" en el funcionamiento del final de carrera. Los cables de los finales de carrera deben ir solos.

Saludos
Re: Problema Homing Eje Z
July 01, 2013 08:53AM
Gracias por la respuesta.

Chequee y re chequee las conecciones, pero descarte todo tipo de problemas de cableado... es algo del firmware que uso (Marlin).

Ya que la secuencia logica se repite y es la siguiente:

Si el Z esta en cualquier lado de la impresora, hago home y hace esto: Toca el final de carrera y se vuelve a levantar (queda aprox a 0,4mm del vidrio).
Pero si el Z ha hecho home previamente, y vuelvo a hacer home, entonces toca el final de carrera suve y vuelve a bajar como corresponderia...

Por lo que la unica manera de imprimir, es hacer home y luego apretar Imprimir (vuelve a hacer un home y luego imprime)... Si me olvido de hacer el home previo a apretar imprimir, entonces la maquina comienza a imprimir en el aire...

es muy raro lo que pasa...
Re: Problema Homing Eje Z
July 02, 2013 03:17AM
Pues es raro ... muy raro ... si tienes el 'workaround' pues nada, a funcionar, pero me da a mi que algo debe estar pasando.

Mi propuesta es:

-Si tan seguro estás que es el firmaware, ¿por qué no cambias a otra versión o a Sprinter?

-Sustitución del final de carrera y cableado de nuevo, evitando poner el cable por donde vayan los otros como los de los motores o cables de alimentación de extrusor o cama caliente.

Saludos
Re: Problema Homing Eje Z
July 02, 2013 03:59AM
Si pongo el Sprinter funciona todo bien...

El problema es que tengo que usar el Marlin obligatoriamente pq tengo una pantalla de LCD y en Sprinter no funciona...

No entiendo muy bien el código de programación como para tocar cosas muy puntuales mas alla de las configuraciones básicas...

Tendría que encontrar la solución para sacar el "doble chequeo", osea, que toque el final de carrera y quede ahi...

saludos
Re: Problema Homing Eje Z
July 03, 2013 02:20AM
Pues si con Sprinter te funciona bien, prueba en versiones anteriores de Marlin si es que no te funciona con la última. Si es un error general supongo que lo habrán reportado ...

Saludos
Re: Problema Homing Eje Z
July 04, 2013 12:25AM
Si quieres usar Marlin, en el fichero Configuration_adv.h busca el parámetro #define Z_HOME_RETRACT_MM y aumenta su valor 1mm hasta que te funcione bien el movimiento. Con eso se te soluciona. Saludos!
Sorry, only registered users may post in this forum.

Click here to login