Welcome! Log In Create A New Profile

Advanced

Movimiento de la empresora

Posted by Juan 
Movimiento de la empresora
February 15, 2013 03:45AM
Hola a todos estamos de regreso.

Preguntas:

La empresora se mueve en brinquitos cuando pusha el primer boton del circulo de protorface - esto es normal?

Cundo muevo el segundo boton en el sirculo este hace un chillido como si trabajar el motor pero no mueve -esto es normal

Yesto es en todos los ejes. (xyz)

Cuando trato de mover el eje Z hay vese que los motores se mueven, pero no parejos por que cuando me fijo el movimiento en el eje X hay vese que se levanta parejo y hay vese que se ladea como si se atora en algun lado - Esto es normal ( pienso que no).

Le saque las tuercas de arriva nomas deje las de abajo y parese que trabaja un poco mejor pero sigue siendo lo mismo. Le puse grasa a las cuatro barillas pero me siguio dando el mismo rsultado. Le afloje las tuercas de abajo a la barilla lisa para ver si acaso estaba cargado hacia un lado -que todo estava a medida pero me da el mismo resultado - que me sujieren.

Tambien le cabie la parte que conecta el motor a la barilla con una de aluminio que segun le ayuda en el movimiento de la barilla por que tiene unas cortadas al rederor de la part pero no resultados sigue haciendo lo mismo.

Espero por su saviduria en estos problemas Gracias.

Juan
Re: Movimiento de la empresora
February 15, 2013 06:03AM
Lo primero siempre es ver si manualmente puedes mover los carros del eje X e Y y si puedes (con las 2 manos) girar las varillas del eje Z. Los motores siempre ejercen resistencia, pero tu deberías moverlos sin problemas.

Los chillidos creo que es síntoma de que no tiene suficiente potencia. Cuando se atranca, es decir, no puede mover el eje ,se escucha otro sonido diferente a un chillido, como un zumbido fuerte.

Si revisas que todo se mueve de forma suave, ya es cuestión de jugar con los potenciómetros (acuerdate de hacer esto con la electrónica apagada), sino, pues como me aconsejaron a mi, desconecta las correas y varillas roscadas (Z) y haz la prueba con los motores libres (sin conexión a las correas y ni varillas ).

También tube un problema con una tuerca de una imprimible en el eje X que impedía que el motor girar la varilla, pero creo que con eso ya te has peleado.

Suerte y paciencia ... que siempre se llega
Re: Movimiento de la empresora
February 15, 2013 07:25AM
Gracias thingmaker. Trabajer este fin de semana en esto y tambien en el estrudor que el plstico no entra facil.
Re: Movimiento de la empresora
February 16, 2013 07:57PM
Tengo una pregunta?

Donde le pongo que mueva 100mm para calibracion para X y Y ?
Re: Movimiento de la empresora
February 18, 2013 04:04AM
Esto se hace en el programa host ... creo que usas el Pronterface, así como verás se puede pedir movimiento de 1mm, 10 mm y 100 mm.

Saludos
Re: Movimiento de la empresora
February 18, 2013 04:12AM
Puedo mover con 10 pero 100 nomas hace un chillido por unos 5 10 segundo y se para el chillido y no mueve. Y eso es para tod los ejes
Re: Movimiento de la empresora
February 18, 2013 04:29AM
Pero de 10 en 10 ... ¿puedes desplazarte de lado a lado de los ejes? a ver si las varillas lisas no están bien alineadas o hay algo que les impide moverse. No obstante puedes engrasar los ejes con aceite 3 en 1 o para máquinas de coser (si tienes)

Si revisas y todo está correcto, yo probaría a darle un cuarto de vuelta más a los potenciómetros a ver si se soluciona.

Saludos
Re: Movimiento de la empresora
February 18, 2013 05:28AM
Las varillas esta engrasada y le trate de dar mas fuersa pero no mejora pare que si cuando le doy mas fuersa al motor este parese hacer un chillido mas alto y parece que asta tiembla un poco

Las barillas esta bie lo muevo con la mando sin tener problemas.bien facil.

Hay algo en el programa que se lo impida mover?
Re: Movimiento de la empresora
February 18, 2013 06:55AM
Creo que es cuestión de ir probando, por si tuviese o no solución :-S, esperemos que sí.

Prueba con bajar la velocidad para los ejes a ver si mejora el tema. Muy importante que hagas el recorrido de 10 en 10 por ratificar que no existe problema físico.

A mi a veces, pero de momento, solo cuando le envío los mandatos desde el pronterface, es que el eje, haciendo una especie de chillidito, la velocidad de moviento cae a la mitad, pero sigue moviendose, aunque más lentamente. Ni idea de porqué pasa ... tampoco he preguntado el por qué.

Saludos y suerte
Re: Movimiento de la empresora
February 18, 2013 09:37AM
Gracias Thingmaker, le trtare esta tarde pero voy a concentrar un eje y luego sigo con el suient.winking smiley

Hay bese que holvido que esto se nesecita mucha paciencia.
Re: Movimiento de la empresora
February 26, 2013 04:26AM
Hola a todos, aqui regreso con este problem de calibracion de los motores (Y, X, Z).

Asta este momento no he podido calibrar estos steppers motors por mas que le intento y nada

Pasos dados.

1.- desconectar computadora de la tarjeta.
2.- desconectar energia electrica.
3.- bajar la corriente en el driver
4.- conectar computadora
5.- poner corriente electrica
6.- tratar movimiento

No movimiento

Contnuar de nuevo con los pasos

Esto pasos cambian en el proceso

3.- pone un poco de coriente

No movimiento nomas sonido del motor

Continuar con los pasos
Movimiento si mas nonido

Se puede mover a los 10 mpero no a los 100

Checar el carruaje de Y, X, y del Z
1.- no problem mover sin problema
2.- quitar banda del eje X, y del Eje Y el motor trabaja sin problema moner un dedo en la polea y poner un poco de presion motor sigue trabajando
3.- poner banda en su lugar
4.- poner mas grasa en loas barillas

Volver a intentar y no movimiento a los 100mm nomas sonido y si pogo mas furza el moto se pone a vibrar y se calienta un poco y tambien el driver.

Alguna sujerencia?
Re: Movimiento de la empresora
February 26, 2013 05:03AM
Si los motores en vacío se mueven y mueven bien cuando tratas de pararlos con la mano, el problema debe estar en el eje.
Revisa que deslizas las partes moviles por el eje con suavidad y sin fricción con la mano.
Re: Movimiento de la empresora
February 26, 2013 10:35AM
Si levanto la epresora de un lado un poco el estruder se deslisa sin ningun problema
Re: Movimiento de la empresora
March 03, 2013 04:10AM
Asegúrate que la velocidad que tienes para el movimiento tanto en los ejes XY como en el Z, no sea muy elevada. Un valor de 500 para XY y de 20 para Z puede ser un comienzo relativamente seguro.

Si a pesar de todo hay algún eje que sólo vibra para todas las posiciones del potenciómetro de ajuste, posiblemente ese driver se haya roto y habrá que cambiarlo.
Re: Movimiento de la empresora
March 03, 2013 06:06AM
Gracias misan, todo esto me tiene fuera de honda, le he tratodo todo en el printer pere el mismo resultado le checare las velocidades.

Hay algun firmware que no tenga que hacer mucho cambios?

No conosco mucho de la programacion.
Re: Movimiento de la empresora
March 03, 2013 06:22AM
Las velocidades se fijan en pronterface, no hay que cambiar el firmware.
Re: Movimiento de la empresora
March 03, 2013 06:42AM
Se lo cambie y trabaja mucho mejo peruna cosa que cuando le pongo 100 mm este (X) se mueve asta el otro lado este es normal?

Eso lo pregunto porque para me no se movia nada nomas hacia sonidos.

Gracias he estado tratando de moverlo por 2tress semanas y no lo habia podido hacer mover.
Re: Movimiento de la empresora
March 03, 2013 07:26AM
Esto se mueve mas normal.

Haora se mueve bastante que si le pongo que se muva 1mm en proterface se mueve 33.45 mm.

Y si le pongo que muva diez se mueve hasta el otro lado pushando el endstop que este desonecta la comunivacion de la epresora de la computadora.
En el programa pronterface me indica esto:

Sending M84

Y si trato de hacer mover los motores me indica esto:

Can't write to printer (disconected?)

Y la unica forma de hacerla trabajar es serrando el protorface y desconectando la empresora de la computadora y de la corriente.

Pregunta esto es normal?
Re: Movimiento de la empresora
March 03, 2013 07:35AM
Juan, ahora tienes que calibrarla, que consiste en colocar en el firmware los valores reales que corresponden a tu impresora, de modo que cuando le digas que mueva 10 mm realmente mueva 10 mm.

No sé por qué una vez toca el endstop te deja de funcionar la comunicación pero de momento no quieres que toque los endstop hasta que no tengas las dimensiones del movimiento más o menos correctas: [reprap.org]
Re: Movimiento de la empresora
March 03, 2013 12:53PM
Como pudo saver a cuantos microstems the driver tien?
Re: Movimiento de la empresora
March 03, 2013 12:55PM
En mi mensaje anterior te incluía un enlace a cómo se obtiene ese valor. Tienes que hacer un pequeño cálculo y luego comprobar y volver a ajustar el valor.
Re: Movimiento de la empresora
March 03, 2013 01:14PM
Si le tratado pero me confundi

Motor_steps_per_rev = 200
Driver_microstep?
Belt_pitch = 2mm
Pulley_number_of_teeth = 36

El stepper microstep es 800

Esto es lo que pide?

Me confundi en esta parte


Me indica esta linea abojo y no entiedo a que se refire,

know what your stepper drivers' microstep is set to. Most set pololus to 16x, GEN3 stepper driver 2.3 is fixed to 2 (half step).
Re: Movimiento de la empresora
March 03, 2013 01:29PM
Normalmente (teniendo los tres jumpers debajo de cada driver puestos) son 16x. Es decir que necesita 16 pulsos para completar un paso (o 3200 pulsos para una vuelta completa).



3200pasos / 36 * 2mm = 44.44 steps / mm
Re: Movimiento de la empresora
March 03, 2013 02:08PM
Gracias misan
Ya le puse en firmware trabaja un poco mejor lo tratare de calibrar
El eje X me da 17.97
44.44*17.97/1 or 100
Re: Movimiento de la empresora
March 04, 2013 03:05PM
Se puede calibra con 1mm a la ves o tiene que ser 100mm?

Preguta es por que cuando le indico que mueva 10mm la empresora mueve como 130mm o serca y mis calipers nomas alcansan 100mm.confused smiley

Y esto es del proceso de calibracion que le hice ayer.
Re: Movimiento de la empresora
March 04, 2013 03:07PM
Lo que necesitas es una distancia, que puede ser cualquiera para luego calcular la relación entre lo que le has pedido que mueva y lo que ha movido realmente para multiplicar por esa relación la medida de pasos/mm.
Re: Movimiento de la empresora
March 04, 2013 03:18PM
Si se mueve 130 o más cuando mandas mover 10, divide los pasos por milimetro entre 10 y así cuando vayas a mirar de nuevo la calibración estará dentro del rango de tu pié de rey
Re: Movimiento de la empresora
March 04, 2013 03:30PM
Gracias misan/electropluma lo intentare esta tarde cuando llege a la casa.luego les cuento los resultados.winking smiley

Gracias por las respuestas rapidas ...thumbs up
Re: Movimiento de la empresora
March 05, 2013 02:26AM
ya queda menos Juan ... ¡ánimo!
Re: Movimiento de la empresora
March 05, 2013 05:20PM
Eso espero, Gracias por toda la ayuda que me an ofrecido.

Estava un poco confundido con la calibracion cada ves que le checo la medida me da algo diferente, y esto me saca de onda o mas bien confundido.

Yo pienso que es mas no entender la calibracion en claro, pero que vamos a hacer mas continuar, pero muchisimas gracias po toda esa eyuda si no me huviera toda muchisimo tiempo con este projecto, una cosa si se que he aprendido bastante y mas que aprendere.

Gracia, Juanthumbs up mantega ese animo tambien y todos saldremos adelate.
Sorry, only registered users may post in this forum.

Click here to login