Welcome! Log In Create A New Profile

Advanced

Dudas sobre los parámetros de configuración Sprinter

Posted by Suca 
Dudas sobre los parámetros de configuración Sprinter
January 11, 2013 03:44AM
[rediok.blogspot.com.es]
Siguiendo esa página nos piden ciertos valores de configuración de los cuales la mayoría los desconocemos. Nuestro modelo de impresora es la Prusa Interaction 2. Si tenéis alguna idea de como averiguar esos valores o si nos los podéis dar, mejor. Principalmente desconocemos los valores de calibración.
nuestro hot end pensamos que es el número 1, y la placa sanguinololu
[www.ebay.es]
Entry Hole:3.00mm
PTFE Insulator Size:16mm
Nozzle Exit Hole:0.50mm
Re: Dudas sobre los parámetros de configuración Sprinter
January 11, 2013 03:59AM
Buenaas, si preguntas por la linea que pone THERMISTORHEATER 1 y viendo el hot end que tienes en ebay, tienes que poner un 6 ya que es un termisor EPCOS de 100k

//// Thermistor settings:
// 1 is 100k thermistor
// 2 is 200k thermistor
// 3 is mendel-parts thermistor
// 4 is 10k thermistor
// 5 is ParCan supplied 104GT-2 100K
// 6 is EPCOS 100k
// 7 is 100k Honeywell thermistor 135-104LAG-J01

#define THERMISTORHEATER 6
Re: Dudas sobre los parámetros de configuración Sprinter
January 14, 2013 03:34AM
Muchas gracias por la información, ademas queremos probar los motores, para saber si la placa funciona (tuvimos que soldar las piezas), el piloto led no se enciende.Si sabeis alguna manera de probar los motores,(aunque la configuración este mal y haya que cambiarla más tarde), o algún programa específico para hacer pruebas, se agradecería.
Re: Dudas sobre los parámetros de configuración Sprinter
January 14, 2013 05:08AM
Para probar los motores lo más simple es con un multimetro medir la continuidad bobina a bobina entre los cables para ver que tienen resistencia alguna.
Re: Dudas sobre los parámetros de configuración Sprinter
January 15, 2013 03:02AM
Instálate algún soft para poder mover en manual, te enumero algunos Repetier, Cura, ReplicatorG, Prontface. A mi personalmente el que mas me gusta es Repetier.

Salu2
Re: Dudas sobre los parámetros de configuración Sprinter
January 20, 2013 08:46AM
Electropluma lo de probar los motores es para comprobar si la placa funciona (no parece dar señales de vida), no es en si por los motores (es que antes no me había explicado muy bien) , y PtxLupen para usar estos programas ¿no habría que tener instalado nada dentro de la placa?, o solo con ellos basta.
Muchas gracias.
Re: Dudas sobre los parámetros de configuración Sprinter
January 21, 2013 12:02AM
Si claro, tienes que tener el firmware cargado previamente te dejo un link que explica como [www.repetier.com] en este tutorial lo explican con el firmware de repetier pero es lo mismo para Splinter o Marlin
Re: Dudas sobre los parámetros de configuración Sprinter
January 24, 2013 12:49AM
Vale, lo hemos subido(Sprinter), aparece done upload,pero también nos da este mensaje:avrdude: AVR Part "atmega1284p" not found
supusimos que habíamos puesto mal la frecuencia del procesador (como lo hay de 8Mhz y 16Mhz), y lo cambiamos pero seguía dando el error.
¿Cómo podríamos arreglar esto?



He seguido buscando un poco más y parece ser que el error, esta en el archivo avrdude dentro de arduino-0023/hardware/tools/etc (esto es posible que ya lo supierais pero bueno)
Y como bien decía el mensaje de error no esta la configuración para la atmega1284p (lo he leido por encima entero, aunque quizas con eso no sea suficiente), pero si que esta para atmega1280 y atmega1281 y al parecer tiene configuraciones identicas, he pensado que lo puede ser tambien para la atmega1284p, y he cambiado los sitios donde ponía atmega1281 por atmga1284p, ahora si encuentra la configuración de la placa pero...
da otro error que creo que son los sitios donde la configuración no esta bien (todo esto que he hecho y dicho son conjeturas, no tengo ni idea de programación), estos son los nuevos errores:
avrdude: stk500_getsync(): not in sync: resp=0x00
avrdude: stk500_disable(): protocol error, expect=0x14, resp=0xfe

Sin alguien me dice como modificar eso o simplemente me pasa un archivo con la configuración correcta para el procesador atmega1284p se agradecería.

Y un dato mas aunque puede que lo presupongais el archivo avrdude es de la versión 0023 de arduino, (descargado de la página oficial).

Edited 2 time(s). Last edit at 01/24/2013 01:09PM by Suca.
Re: Dudas sobre los parámetros de configuración Sprinter
January 24, 2013 12:28PM
Revisa que el puerto com que has seleccionado es el adecuado.
Revisa que la placa que has seleccionado es la adecuada.
Y comprueba que parpadean las luces mientras graba los datos en el arduino.
Re: Dudas sobre los parámetros de configuración Sprinter
January 24, 2013 01:08PM
Comprobado, no funciona,ademas el led no se ha llegado a encender nunca, suponía que es que se había fundido,pero, ¿podría significar que hay algo mas estropeado en la placa?

Por cierto había editado mi anterior mensaje con algunas conjeturas (las cuales pueden estar mal) , basadas en unas búsquedas que he estado haciendo.
Re: Dudas sobre los parámetros de configuración Sprinter
January 24, 2013 02:48PM
Pero estás poniendo la confirguación dentro de los .h del firmware ¿o estas seleccionando la placa desde el menú del programa arduino?
Re: Dudas sobre los parámetros de configuración Sprinter
January 25, 2013 03:03AM
Si te refieres a lo que he puesto ante que he cambiado de la configuración avrdude es dentro de los archivos de arduino (no tiene nada que ver con sprinter que yo sepa ), pero si lo que dices es lo de modificar el numero de la placa en configuration.h y despues en arduino dentro de tools poner la placa sanguinololu eso si esta hecho y no parece que haya ningun problema con eso
Sorry, only registered users may post in this forum.

Click here to login