Welcome! Log In Create A New Profile

Advanced

La plataforma se calienta con solo encender la fuente

Posted by Mecano 
La plataforma se calienta con solo encender la fuente
November 18, 2012 02:53PM
Bueno estoy empezando a pensar que algo dentro del Arduino o mi RAMPS 1.3 se ha quedado puenteado. El problema es que nada mas encender la fuente se empieza a calentar la plataforma. Sin ni siquiera haber conectado el programa Host. Cuando lo conecto, veo como va subiendo la temperatura, intento dar la orden de apagar la plataforma pero no hace ni caso. Esto me pasa tanto en el Repetier host como en el Pronterface.

He probado a cargar nuevamente el firmware en el Arduino pero sigue pasando exactamente igual.

¿A alguien le ha pasado esto?
Re: La plataforma se calienta con solo encender la fuente
November 18, 2012 03:47PM
Puede ser por firmware (que hayas puesto en pina.h alguno que no sea) o puede ser por hardware (una pista que toque con la de la cama, un mosfet que se ha quedado en corto).

Prueba a hacer dos cosas:
- con el arduino desenganchado de la ramps, comprueba si el pin indicado responde a la señal de apagado y encendido. Por ejemplo un led con una resistencia de 1kohm te servirá para verlo. También con un multimetro en función de voltímetro.

- Comprueba que con el ramps desenganchado del arduino, y con la corriente puesta la cama no se caliente.
Si se calienta la cama con el ramps desenganchado del arduino con solo aplicarle corriente de la fuente, yo cambiaría directamente el mosfet (son 2min con el soldador y cuesta unos céntimos) para comprobar si se corrige el problema.
Re: La plataforma se calienta con solo encender la fuente
November 19, 2012 06:04AM
Gracias por tu rápida respuesta Electropluma,

Voy a probar primero por si es el mosfet, Mi RAMPS tiene 3, supongo que será uno para cada salida: plataforma, ventilador y extrusor. Los tres son exactamente iguales ¿no?. Es que actualmente no tengo ventilador entonces como prueba podría cambiar en el firmware que la salida de la Heated Bed fuera la del ventilador poner los cable de ahi... y ver si todo vuelve a funcionar.
Re: La plataforma se calienta con solo encender la fuente
November 20, 2012 03:30PM
Pues si, era el mosfet, lo he susttuido y durante un rato ha ido bien. Cuando le he dado caña se ha quemado el mosfet angry smiley.

Supongo que es porque me han vendido uno con algo menos de amperios a parte de que estoy probando mi nueva plataforma calefactada MK2.
Re: La plataforma se calienta con solo encender la fuente
November 20, 2012 05:24PM
si le pones un ventilador a la ramps??
Re: La plataforma se calienta con solo encender la fuente
November 21, 2012 12:45AM
Mide con un multimetro la plataforma MK2 a ver que resistencia tiene.
También puedes poner un fusible en una de las lineas d ela plataforma par aprevenir que se quemen los mosfets
Re: La plataforma se calienta con solo encender la fuente
November 25, 2012 03:53AM
La MK2 da una resistencia de 1.5 ohmios en frio.

He puesto un nuevo Mosfet pero esta vez con un disipador. El disipador se pone muy caliente muy rápido (en 2 o tres segundos ya no puedes tocarlo). De todas formas no funciona bien, durante un minuto o dos manda corriente, después se ve que se protege por la temperatura y deja de enviar corriente, si corto y espero que se enfrie el disipador (unos 20-30 segundos) cuando vuelvo a encender vuelve a funcionar y consigue elevar la temperatura de la cama un poco mas pero termina dejando de enviar corriente (lo noto porque la fuente hace menos riudo).

En el programa Repetier no sale ningún error, sigue Calentando cama, si yo no lo paro, sigue permanentemente dando la orden de calentar cama, con lo cual el Mosfet no se enfría.

Las opciones que creo que me quedan son:

1) Un mosfet mas gordo.

2) Un disipador mas gordo.

3) La combinación de ambas
Re: La plataforma se calienta con solo encender la fuente
November 25, 2012 09:29AM
12/1.5 = 8 Amp.

Los STP55NF06L de la ramps 1.3 deben funcionar de sobra con ese amperaje. Más si les has puesto disipadores.
¿Estás seguro de que no tienes algo más consumiendo en paralelo en esa salida?

Mide la corriente del cacharro mientras calienta a ver que amperaje sale.
Sorry, only registered users may post in this forum.

Click here to login