Welcome! Log In Create A New Profile

Advanced

How to set first layer print height?

Posted by AgeingHippy 
How to set first layer print height?
February 05, 2011 03:52AM
Hello All

I am trying to do my first print with reprap host creating and printing my gcode.

It seems to print the first layer at 0.7mm although my filament width is 5mm.

Weirdly enough where it says layer 1 & layer 2 it simply moves the Z acis up a little and homes X & Y and delays a while. What is all that about?

gcode follows...

; GCode generated by RepRap Java Host Software
; Created: 2011-02-05:11-32-48
G21 ;metric is good!
G90 ;absolute positioning
M140 S55.0 ;set bed temperature and return
T0; select new extruder
M113; set extruder to use pot for PWM
G92 E0 ;zero the extruded length
G28; go home
G92 E0 ;zero the extruded length
G1 F5.0; feed for start of next move
G1 Z0.4125 F50.0 ;z move
G1 Z0.5875 ;z move
G1 Z1.0 F5.0 ;z move
G1 F1500.0; feed for start of next move
G1 X2.8 Y0.1 F3000.0 ;horizontal move
G1 X127.2 Y4.9 ;horizontal move
G1 X130.0 Y5.0 F1500.0 ;horizontal move
G28 Z0 ;set z 0
M109 S195.0 ;set temperature and wait
G1 F3000.0; feed for start of next move
G1 E1000.0; extruder dwell
G1 F1500.0; feed for start of next move
G1 F18000.0; feed for start of next move
G1 E960.0; extruder retraction
G1 F1500.0; feed for start of next move
G92 E0 ;zero the extruded length
;#!LAYER: 1/35 joggles about doing nothing usefull - why?
G4 P21 ;delay
M107 ;cooler off
G4 P20 ;delay
G1 F5.0; feed for start of next move
G1 Z-0.02 F33.2 ;z move
G1 Z0.16 F5.0 ;z move
M106 ;cooler on
G28 X0 ;set x 0
G28 Y0 ;set y 0
;#!LAYER: 2/35 again joggles about doing nothing usefull - why?
G4 P94 ;delay
M107 ;cooler off
G4 P20 ;delay
G1 F5.0; feed for start of next move
G1 Z0.28 F27.3 ;z move
G1 Z0.4 F5.0 ;z move
M106 ;cooler on
G28 X0 ;set x 0
G28 Y0 ;set y 0
;#!LAYER: 3/35 actually starts printing this layer
G4 P94 ;delay
M107 ;cooler off
G4 P20 ;delay
G1 F5.0; feed for start of next move
G1 Z0.55 F30.4 ;z move
G1 Z0.7 F5.0 ;z move moves to Z = 0.7mm but my filament diameter is 0.5 WTF?? which reprap host setting do i change3 to fix this?
T0; select new extruder
M113; set extruder to use pot for PWM
G1 F1500.0; feed for start of next move
G1 X1.9 Y2.1 F3000.0 ;horizontal move
G1 X78.1 Y85.9 ;horizontal move
G1 X80.0 Y88.0 F1500.0 ;horizontal move
G1 F18000.0; feed for start of next move
G1 E4.0; extruder dwell
G1 F1500.0; feed for start of next move
G1 F3000.0; feed for start of next move
G1 E5.0; extruder dwell
G1 F1500.0; feed for start of next move
G1 F3000.0; feed for start of next move
G1 E6.0; extruder dwell
G1 F1500.0; feed for start of next move
G1 X79.4 Y90.8 E8.9 F3000.0 ;horizontal move
G1 X78.7 Y94.6 E12.7 ;horizontal move
G1 X78.0 Y98.0 E16.2 F764.6 ;horizontal move
Re: How to set first layer print height?
February 09, 2011 11:21PM
Quote

G1 Z0.7 F5.0 ;z move moves to Z = 0.7mm but my filament diameter is 0.5 WTF?? which reprap host setting do i change3 to fix this?

The preference settings that you need to change are Extruder0_ExtrusionHeight(mm) and Extruder2_ExtrusionHeight(mm). They have to match. Note that Extruder 2 is used for infill by default. If you enable support, then you need to change Extruder 1 also since that's used for support. The height seems to not depend on the ExtrusionSize (in Extruder0, 1 and 2) which should be set to your filament size.
Re: How to set first layer print height?
February 10, 2011 01:54AM
Thanks dude

I have since moved on to Skeinforge, but it is stillusefull to know - and others may find this info usefull.
Sorry, only registered users may post in this forum.

Click here to login