Welcome! Log In Create A New Profile

Advanced

Arduino / ramps qui plante avec led verte clignotante.

Posted by Nossolov 
Arduino / ramps qui plante avec led verte clignotante.
May 02, 2018 11:10AM
Bonjour.
Je suis en cours de montage d'une delta et je coince sur un probléme de plantage de l'arduino.
Tout fonctionne plutôt pas trop mal, mais lorsque je demande un Home Z de "trop loin" (plus de 400mm), tout s’arrête à peu prés toujours à 30 ou 40mm des butées, l'arduino refuse de communiquer avec le PC, les commandes de l'écran ne répondent plus, la touche reset de la ramps ne donne rien non plus, la LED verte de la ramps clignote plein pot. Pour retrouver la main, il faut couper toutes les alimentations de l'arduino (usb et alim de puissance), et ça remarche normalement.
Si je bouge par pas de 100mm, quelque que soit la direction, tout va bien. Si je suis à moins de 350mm des butées, le Home Z se passe très bien.
Je viens de voir ce soir que le problème se produit aussi sur un autocalibrage G33 P1 : tout semble bien se passer au début, ça descend tranquille, puis ça passe d'un coup en vitesse maxi et ça s'arrête avant d'arriver en bas, tout planté de la même façon.
Sais pas trop quoi faire sur ce coup....
Si vous avez des idées...
Vais peut être passer sur mon MKS 32bits plus tôt que prévu.
Merci d'avance.
Re: Arduino / ramps qui plante avec led verte clignotante.
May 02, 2018 11:51AM
Je viens de refaire une série de tests.
Ca plante au delà de 400mm sur le homing. Jusqu'à 400, ça marche à tous les coups, à 410, ça plante.
Y aurait pas une sécurité dans le firmware Marlin qui traine quelque part ???
Re: Arduino / ramps qui plante avec led verte clignotante.
May 03, 2018 12:27AM
Salut.
J'ai pas tout analysé le code mais j'ai déjà eût la même chose. Il est fort probable qu'il y ai une sécurité pour éviter de percuter le lit si ça touche et que les contact ne déclenchent pas...
Après, le temps que le lit chauffe, tu as le temps de descendre la tête vers une position "acceptable".
C'est une vraie contrainte de mise en oeuvre cette limitation?

@+
Re: Arduino / ramps qui plante avec led verte clignotante.
May 03, 2018 04:35AM
C'est un peu embêtant quand même de ne pas pouvoir se servir de toute la capacité de la machine sans avoir à "ruser". Bon, pour l'instant, y'a un peu de travail pour le calibrage donc on va tenter de contourner le problème.
Re: Arduino / ramps qui plante avec led verte clignotante.
May 03, 2018 11:58AM
En fait, je pense qu'il faut voir ça comme la préparation à l'impression:
- mise en chauffe;
- chargement du G-code;
- filament restant;
- tension de courroies;
- homing;

C'est parti...
en fin:
- vérification visuelle rapide de la pièce;
- Z à 10, X à 140, Y à 0;
- sortie pièce.

C'est comme ça que je procède et il semblerait que ça m'évite plusieurs problèmes... C'est un peu comme quand tu parts en vacances en voiture: plein, huile, pression, pare-brise...

Merci @+
Re: Arduino / ramps qui plante avec led verte clignotante.
May 04, 2018 01:50PM
Bon, problème résolu !
Je ne suis pas contre (bien au contraire) le petit tour du propriétaire avant les impressions, mais un plantage que je n'arrive pas à expliquer et qui peut se produire pendant n'importe quelle impression, ça m'ennuie.
J'avais déjà un gros doute sur la capacité de l'arduino à gérer les trajectoires des deltas. En farfouillant sur Github section Marlin, d'autres testeurs ont rapporté des comportements similaires suite à l'augmentation des vitesses de déplacement. Pour tester ça, j'ai la machine "idéale" : moteurs à 400 pas par tour et drivers en 32 micropas. Avec la config de base Marlin (Feedrate homing Z = 200 x 60), l'arduino est rapidement dépassé et reboot. Si on tombe à 50 x 60, ça marche bien mieux, mais moins vite. C'est confirmé par les spécialistes Marlin sur Github : l'arduino ne peut pas suivre. Passage aux gros processeurs obligatoire !
Cerise sur le gâteau : la commande G33 semble maintenant fonctionner.
Re: Arduino / ramps qui plante avec led verte clignotante.
May 04, 2018 02:06PM
Ah merde, j'avais pas intégré que c'était une delta.
Quand j'avais cherché à m'en monté une, il était effectivement très rapidement apparu qu'un arduino pourrait être assez (trop ?) léger. Les détails sont ICI
Il y a des solutions mais ça a l'air tout de suite plus chère... Après, ça fait parti du jeu.

@+
Re: Arduino / ramps qui plante avec led verte clignotante.
May 05, 2018 04:13AM
Pas beaucoup plus cher en fait : Les MKSbase 1.3 avec écran tactile sont devenues abordables. En plus, on a droit à des drivers moteur qui passent 2A.
Re: Arduino / ramps qui plante avec led verte clignotante.
May 05, 2018 04:53AM
Du coup, ça dit quoi comme prix au total hors alim et stepper?
Ca pourrait m'intéresser pour un MPCNC qui demande un peu plus qu'un arduino peut fournir...

@+
Re: Arduino / ramps qui plante avec led verte clignotante.
May 06, 2018 10:03AM
On trouve les MKS 32bits + écran tactile autour de 80 / 90 euros sur amazon. Les drivers sont soudés sur la carte avec leurs radiateurs.
Chez Emotion tech, ils ont aussi leur carte 32 bits, également compatible smoothieware, pas très cher non plus.
C'est moins meilleur chez ali, mais faut avoir confiance...
Sorry, only registered users may post in this forum.

Click here to login