Welcome! Log In Create A New Profile

Advanced

Prusa I3

Posted by grudulin 
Prusa I3
April 01, 2018 03:56AM
Bonjour à toutes et à tous,

Voilà deux ans, je me suis lancé dans la construction d'une Prusa I3 en suivant ce tuto : [vvinch.blogspot.fr]

Par manque de temps, je n'ai pas finalisé la configuration, chose à laquelle je m'attelle ce weekend

Après modifications sur firmware marlin et injection dans l'arduino, j'arrive à bouger les axes, toutefois,le homing ne fonctionne pas ( les axes ne reviennent pas sur les endstop), et lorsque je lance l'impression d'un cube de 20MM, ben c'est un peu le carnaval

Je cherche depuis hier à modifier la configuration de mon firmware, en parcourant les forums,mais rien à faire, la situation n'évolue guère...

Je joins mon fichier configuration.h

Merci pour votre aide winking smiley
Attachments:
open | download - Configuration.h (64.8 KB)
Re: Prusa I3
April 01, 2018 09:10AM
les trois quart des tutos sont obsolete

[marlinfw.org]
Re: Prusa I3
April 01, 2018 11:17AM
Merci pour le lien,en effet, le fait que les tutos soient obsolètes n'arrange pas mes affaires
Je suis reparti d'un firmware marlin 1.0, pour le moment, les axes X et Y répondent bien (se déplacent dans le bon sens, et s'arrêtent sur le endstop), par contre, mon Z lui ne veut que monter,et ne refuse de descendre...
J'arrête pour aujourd'hui, et reprendrai demain
Re: Prusa I3
April 01, 2018 01:00PM
Ben s'il ne fait que monter, c'est que soit la prise de moteur est à l'envers soit Marlin n'est pas correctement configuré.
J'ai une Itopie (c'est presque comme une prusa...) je te joins mon fichier de config.
Il y a des choses a chercher pour avoir le bon sens de rotation.

Je regardes vite fait s'il y a des trucs qui choquent et je te dit.

@+

edit: A ben non, t'as pas mis ton .h

Edited 1 time(s). Last edit at 04/01/2018 01:05PM by albertdela.
Attachments:
open | download - Configuration.h (59.4 KB)
Re: Prusa I3
April 02, 2018 02:48AM
hello,

Merci pour ton fichier, je vais regarder çà

Je te joins mon .h que j'utilise actuellement winking smiley
Attachments:
open | download - Configuration.h (34.6 KB)
Re: Prusa I3
April 02, 2018 09:28AM
Salut.
Je suis étonné que ça compile mais bon, admettons.
Tu as inversé la direction du Z : "#define INVERT_Z_DIR true" il y a une raison?
Tu fais le homing sur le Xmax? "#define X_HOME_DIR 1" du coup attention: "//#define ENDSTOPPULLUP_XMAX" faudrait peut-être la décommenter...

@+
Re: Prusa I3
April 10, 2018 04:57AM
hello,
Oui, sous Arduino 1.0.5 je n'ai pas de problème de compilation
Pour le Z, et bien c'est parceque dans la config initiale, le Z descendait lorsque je lui demandais de monter, et inversement
Mon capteur de fin de course étant sur le XMAX, je pensais que le homing se fait donc dessus.
C'est une erreur à corriger?
Merci

P.S : en parcourant le forum, je viens de m'apercevoir que je n'avais pas mis les cavaliers sous les pololus, déjà, le fonctionnement de l'imprimante est un peu plus correct, le seul souci qui me reste pour le moment, est que mon endstop Z, qui est placé en bas sur l'imprimante,ne fonctionne pas. Lorsque je fais la commande M119 depuis repetier, il apparait toujours en open, qu'il soit relaché ou appuyé. J'ai tenté avec un endstop neuf, même problème. Par contre, si je place le endstop sur le connecteur ZMAX de la carte RAMPS, là il passe bien de open à trigger...

Edited 1 time(s). Last edit at 04/10/2018 08:34AM by grudulin.
Re: Prusa I3
April 10, 2018 09:32AM
Ben oui mais non...
Si tu lui dit "#define INVERT_Z_DIR true" c'est que tu cherches à inverser la logique de commande du Z alors que précédemment tu nous dit : "mon Z lui ne veut que monter,et ne refuse de descendre..." Du coup, il y a des trucs à l'envers l'un de l'autre... Un petit manque de cohérence.
Regardes bien les définitions des logiques de pilotage et celle de fin de courses si tu inverses tout à chaque fois ça va pas fonctionner. Je pense qu'il vaut mieux ne pas inverser les logiques et retourner les prises de moteur.
Dis nous où tu en est et on voit ça...

@+
Re: Prusa I3
April 10, 2018 11:37AM
Merci pour les précisions albertdela

Bon, et bien, après avoir corriger ce problème de cavalier, je suis reparti sur le dernier firmware marlin disponible sur leur site
Après avoir configuré le config.h en reprenant ce que j'avais fait auparavant, j'obtiens un résultat correct : les 3 axes se déplacent correctement, reprennent leur position par rapport au endstop lorsque je Home ^^

J'ai quelques réglages encore à effectuer pour avoir 10mm sur repetier et 10mm en réel ( disons que çà se joue à 2mm max), j'ai mon ventilo d'extruder qui ne se déclenche pas ( je vais vérifier les soudures), et emporté dans mon élan, j'ai tenté une impression en PLA 1.75mm, quelques filaments sont sortis, puis Hotend et buse bouchés :s Je pense que çà vient qui ne s'active pas

Donc, prochaines étapes : nettoyage complet HotEnd et buse, réglage des moteurs, et re-test d'impression

Je mets mon config.h en pièce jointe, si jamais vous voyez quelquechose de "carnaval" winking smiley

Merci pour votre aide, et l'aide procurée par le forum
Attachments:
open | download - Configuration.h (64.8 KB)
Re: Prusa I3
April 10, 2018 02:22PM
Bon ben content que ça fonctionne.
En théorie, c'est assez facile à régler l'ensemble.
Je ne connais pas ton niveau et où tu en es dans les réglages de ta machines mais je te conseille ceci: réglage PID . Déjà, ta buse fonctionnera plutôt bien.
Ensuite, pour tout régler, j'utilise ça . Ca paie pas de mine mais c'est plutôt efficace...
@+
Sorry, only registered users may post in this forum.

Click here to login