Welcome! Log In Create A New Profile

Advanced

Prob. avec lecteur de carte SD Marlin 1.1.8

Posted by Underscore 
Prob. avec lecteur de carte SD Marlin 1.1.8
January 26, 2018 11:35AM
Bonjour à tous,

Je ne débute pas dans l'impression 3D, mais là, je bloque sur un point...

J'ai une prusa i3 de chez e-motion Tech et j'ai voulu " mettre " à jour mon firmware pour bénéficier des dernières nouveautés. Bien mal m'en a pris !

La configuration de Marlin est un peu mieux fichue que pour la 1.0.... mais mon lecteur SD ne fonctionne plus depuis la mise à jour.

J'ai ça comme écran de contrôle et avant que je ne " migre " vers la version 1.1.8, il fonctionnait convenablement, je pouvais avoir accès à tout ce qui était sur la carte SD, mais depuis, plus rien et pourtant rien n'a changé...

J'ai bien dé-commenté la ligne d'activation du lecteur SD, j'ai tenté des vitesses de lecture différentes (lignes 1341, 1342 ou 1343 du configuration.h).

J'ai contrôler les nappes, des fois que, mais rien de spécial, j'ai même essayé avec un autre écran, comme celui-là, mais ça fait pareil...

Je ne m'explique pas d'où ça vient... J'ai la carte détectée, mais illisible (" carte insérée " mais " pas de carte " quand je rentre dans le menu).

Si quelqu'un a eu le même problème et qu'il a trouvé une solution, je suis preneur !

Merki.
Re: Prob. avec lecteur de carte SD Marlin 1.1.8
January 26, 2018 01:37PM
Salut.
Je n'ai fait aucune mise à jour et je crois que je suis parti direct sur le 1.1.8. Depuis très peu, j'ai aussi, parfois, ce genre de problème. La seule façon de s'en sortir, chez moi en tout cas est de resortir du menu, sortir la carte et refaire la manip. A priori, ça fonctionne à chaque fois...
J'ai pas d'idée et je vais suivre pour voir si quelqu'un a une manip meilleure (j'avoue la mienne est ... pourrie).

@+
Re: Prob. avec lecteur de carte SD Marlin 1.1.8
January 26, 2018 11:05PM
En effet, ce n'est pas ce qu'il y a de plus protocolaire, mais j'ai essayé aussi cette option et rien n'y fait !

Pas d'effet...

Merci quand même.

Si quelqu'un peut nous dépanner du coup, on prend !
Re: Prob. avec lecteur de carte SD Marlin 1.1.8
January 31, 2018 02:41PM
Re,

Bon, ben je vois que ça ne passionne pas les foules mon problème de lecteur de carte SD... sad smiley

@albertdela : peux-tu me donner ton configuration.h que je puisse comparer avec ma version ?

Merci.

Et je suis toujours ouvert aux propositions ! smiling bouncing smiley
Re: Prob. avec lecteur de carte SD Marlin 1.1.8
February 01, 2018 02:26AM
Tu as essayé avec une autre carte . Ou plus simplement de la reformater.

Dans ton fichier de config il faut l'activer, cars le fait d'activer l'écran ne suffit pas. Avant effectivement, c’était activé d'office lors de l'activation de l'écran.

Je n'ai personnellement aucun problème avec ce firmware (1.1.8), bien au contraire, la lecture est plus fiable et rapide et la détection nickel.
Re: Prob. avec lecteur de carte SD Marlin 1.1.8
February 01, 2018 12:06PM
Merci Biostrike pour ta réponse,

J'ai bien activé le lecteur SD, puisqu'il me dit : pas de carte quand j'entre dans le menu. Sinon (et j'en ai déjà fait l'expérience) il n'indique que le menu de base, sans la lecture de carte.

Oui, j'ai déjà essayé avec d'autres cartes, formatées différemment et tout et tout. Ce qui me paraît bizarre, c'est qu'en ayant changé de firmware, le lecteur ne fonctionne plus. Alors qu'avec l'ancien (1.0), tout allait bien.

Est-ce que quelqu'un peut me filer son configuration.h, que je compare ?

Tanque iou !grinning smiley
Re: Prob. avec lecteur de carte SD Marlin 1.1.8
February 01, 2018 12:12PM
Tu fais bien de me le demander parce que du coup je ne sais pas le retrouver!
Si jamais un jour ça pête, je n'ai plus de sauvegarde...
Re: Prob. avec lecteur de carte SD Marlin 1.1.8
February 05, 2018 11:58AM
Toujours pas d'idée pour mon pb ou personne ne veut m'aider ??? sad smiley

J'ai maintenant un autre problème, depuis le changement de ventilo sur ma buse (à priori, rien à voir)...

Concernant mon Z offset, j'ai beau le régler comme il faut avec l'écran LCD, lors de la première couche, la buse est trop haute...

J'augmente la distance, et rebelote, ça fait pareil, toujours la même distance au démarrage... Si vraiment j'augmente un bon coup, la buse frotte et rien ne sort !!!

Je précise que la méthode de passer par Repetier pour régler l'offset ne fonctionne pas chez moi, une fois que l'inductif à capté, plus de descente possible, même en forçant avec un G92 Z10, la buse ne descend pas plus bas... (d'autant que dans Repetier, Z reste à 0.00).

angry smiley Je rage !

Merki aux âmes charitables.
Re: Prob. avec lecteur de carte SD Marlin 1.1.8
February 05, 2018 12:13PM
Salut.
Et si tu décale le capteur ?
A priori, mettre une offset alors que tu as un capteur inductif n'a pas de sens parce que justement le capteur sert à se passer de tous les calculs de hauteur et compagnie.
Que tu ne puisses pas descendre après c'est normal aussi puisque, à priori, la capteur sert à trouver le point bas...

@+
Re: Prob. avec lecteur de carte SD Marlin 1.1.8
February 05, 2018 02:43PM
Merci albertdela,

Je testerai ça plus tard. Mais il me paraît étonnant que d'une version ancienne de marlin (1.0.5 je crois) à une dernière version, il y ait autant de changements... et moins de trucs qui fonctionnent chez moi et qui fonctionnaient avant... Cependant, je ne remets pas en question ce qui a été fait pour améliorer le firmware !

Par contre, en ce qui concerne la procédure pour l'offset, avant (version 1.0.5), je suivais ce que me disait le manuel de ma prusa emotion tech, je pouvais encore descendre, même en ayant capté le plateau. J'ai bien une vis de réglage sur le capteur capacitif, mais c'est tellement sensible que j'ai pas pu avoir mieux qu'environ 2mm de décalage entre la buse et le capteur...

J'ai même tenté de modifier directement dans le firmware et re-téléversé, ça n'a rien changé.

Je vais encore creuser, je vais bien finir par trouver quelque chose... Tout ça parceque j'ai optimisé le ventilo de ma hotend... Ça m'apprendra à vouloir upgrader tiens !

Je reste open à toute proposition concernant mon lecteur de carte SD ! C'est avant tout pour ça que j'ai posté ce message à la base... spinning smiley sticking its tongue out
Re: Prob. avec lecteur de carte SD Marlin 1.1.8
February 05, 2018 05:07PM
Salut,

Je sais pas pour la carte SD, mais pour les mouvements, on dirait que ça vient des MIN_SOFTWARE_ENDSTOPS

Sur les anciennes versions de marlin, c'était
#define min_software_endstops false // If true, axis won't move to coordinates less than HOME_POS.

Dans la 1.1.8 on trouve a priori ça:
// Min software endstops curtail movement below minimum coordinate bounds
#define MIN_SOFTWARE_ENDSTOPS
#if ENABLED(MIN_SOFTWARE_ENDSTOPS)
  #define MIN_SOFTWARE_ENDSTOP_X
  #define MIN_SOFTWARE_ENDSTOP_Y
  #define MIN_SOFTWARE_ENDSTOP_Z
#endif

// Max software endstops curtail movement above maximum coordinate bounds
#define MAX_SOFTWARE_ENDSTOPS
#if ENABLED(MAX_SOFTWARE_ENDSTOPS)
  #define MAX_SOFTWARE_ENDSTOP_X
  #define MAX_SOFTWARE_ENDSTOP_Y
  #define MAX_SOFTWARE_ENDSTOP_Z
#endif

Du coup, si je comprends bien en changeant
#define MIN_SOFTWARE_ENDSTOPS
par
//#define MIN_SOFTWARE_ENDSTOPS

Ou
#define MIN_SOFTWARE_ENDSTOP_Z
par
//#define MIN_SOFTWARE_ENDSTOP_Z

Tu devrais retrouver ton ancien comportement, a savoir pouvoir descendre sous le Z0
Re: Prob. avec lecteur de carte SD Marlin 1.1.8
February 05, 2018 10:05PM
Merci Grim,

Je testerai ça ce soir...

Pas bête.

Pour mon souci de SD, j'ai aussi comparé ce qu'il y avait avant et maintenant et j'ai bien l'impression que ça n'est pas défini pareil. J'ai rajouté des lignes, mais ça n'a rien changé. D'ailleurs, j'ai rien compris à ce que j'avais rajouté mais coup de bol, pas d'erreur de compilation !

À suivre...

Je suis pas au bout de mes peines. Surtout si je veux me lancer dans une core XY un de ces jours...

Edited 1 time(s). Last edit at 02/06/2018 06:48AM by Underscore.
Re: Prob. avec lecteur de carte SD Marlin 1.1.8
February 07, 2018 09:23AM
A y est !!!

Merci pour vos conseils (@Grim et @albertdela), j'avais voulu paramétrer marlin comme " avant " (avec la version d'e-motion tech), et en fait j'aurais dû commencer par le commencement, c'est à dire : lire et comprendre !!!

Concernant mon problème de lecteur SD : résolu (en comparant la version e-motion tech et la 1.1.8, j'avais changer le pin du SDSS - ligne 247 dans pins_RAMPS.h)

Concernant la descente " en dessous " du zéro : résolu aussi. Merci à Grim, c'est maintenant possible.

Je ne sais pas passer le topic en " résolu " alors, ben tant pis. Ou alors, j'ai pas trouvé, ou j'ai pas lu...

À bientôt pour de nouveaux problèmes !!! drinking smiley
Re: Prob. avec lecteur de carte SD Marlin 1.1.8
February 07, 2018 11:16AM
Super! bon boulot et merci du retour.
@+
Sorry, only registered users may post in this forum.

Click here to login