Welcome! Log In Create A New Profile

Advanced

Pas par mm extruder

Posted by djedjey 
Pas par mm extruder
August 15, 2017 03:58AM
Bonjour,

J'ai un extrudeur MK8 avec moteur NEMA 17 1,8°, vis à griffe diamètre 10,88mm, stepper A4988, ramps 1.4 avec 3 jumper sur l'emplacement du stepper.
Avec la petite formule qui va bien j'arrive à 93 step/mm. Or quand je lance une extrusion de 10mm j'en consomme environ 5mm soit 50%.
Avez vous déjà rencontré ce genre de problème? Merci d'avance pour vos suggestions!

Cordialement
Re: Pas par mm extruder
August 15, 2017 10:45AM
Avec une configuration semblable, et après ajustements, je suis a 97 pas/mm. Extruder 5mm au lieu de 10, on est loin de l'ajustement classique...
Question bete, mais on ne sait jamais : le filament est il bien entrainé dans ton extrudeur? (pas de glissement / grignotage)?

Quelques pistes :
  • je ne sais pas quel firmware tu utilises, mais essaie de vérifier que le nombre de uStep est bien 16.
  • essaie de changer le driver moteur
  • essaie de mettre le driver moteur sur le deuxième emplacement extrudeur de la ramps et de configurer ton firmware en conséquence
Re: Pas par mm extruder
August 15, 2017 02:29PM
Salut,
Tu fais une règle de 3:
(nombre_de_pas*distance_voulue)/distance obtenue
(93*10)/5=186
Re: Pas par mm extruder
August 15, 2017 11:06PM
tu a vérifier tes 3 jumper sous le driver il y en aurai pas un sans le contact métallique

il faut vérifier le voltage du stepper A4988 si c'est trop bas tu perd des pas
Re: Pas par mm extruder
August 16, 2017 02:35AM
Un rapport de 1 à 2... Tu devrais vérifier que ton moteur n'est pas un 0,9° par pas au lieu de 1,8° peut-être ?

Edited 1 time(s). Last edit at 08/16/2017 02:36AM by DeuxVis.

Most of my technical comments should be correct, but is THIS one ?
Anyway, as a rule of thumb, always double check what people write.
Re: Pas par mm extruder
August 16, 2017 05:36AM
Merci pour vos conseils. Après avoir essayé de nouveaux composants j'avais toujours le même problème. J'ai donc fait des tests avec la sortie E1 au lieu de E0 de la ramps, et la avec les mêmes composants ça fonctionne...
Je me demande si ma ramps ne déconnerait pas.
Re: Pas par mm extruder
August 16, 2017 12:27PM
il est possible qu'une soudure soit défectueuse sur la ramps. Si tu as le matériel adéquat, tu peux essayer de rebraser les soudures.
L'autre possibilité c'est que le PCB de la ramps soit détérioré (une piste coupée ou mal gravée).

Enfin le principal, c'est que cela fonctionne à présent!
Re: Pas par mm extruder
August 28, 2017 01:03AM
Bonjour,

Et le service après vente du produit, et la garantie ?

Tenez-nous au courant.

Cordialement,

L'ami René


Un pour tous et tous pour un !
One for all and all for one !
Imprimante 3D : Geeetech Rostock 301 dysfonctionnelle modifiée
Aide pour la configuration d'une delta Geeetech Rostock 301
Sorry, only registered users may post in this forum.

Click here to login