deux ou trois questions sur la gen7 et teacup.
February 08, 2012 02:26PM
Bonsoir,
Bon, voilà ma deuxième prusa est construite, la voilà posée dans la bibliothèque de l'école, (donc pas sous mes yeux avant demain, au cas où il y ai des réponses avant).
Les moteurs tournent, (Z est un peu duraille, mais j'y travaille).
Par contre j'ai bien regardé mais pas assez peut-être, je le branche où mon ventilateur pour la tête ?
Et mes lectures de températures sont très hautes, 458°, demain je vérifie les soudures, mais j'ai regardé dans teacup et je ne sais où définir la thermistance.
Voilà pour le moment c'est tout ce que je vois.
Ah oui, vous suggérez quoi ? 1/16 ? ou 1/8 ?

Merci d'avance.
Re: deux ou trois questions sur la gen7 et teacup.
February 09, 2012 12:11AM
Bonjour je prends tes questions dans l'ordre.

>Bon, voilà ma deuxième prusa est construite, la voilà posée dans la bibliothèque de l'école, (donc pas sous mes yeux avant demain, au cas où il y >ai des réponses avant).
>Les moteurs tournent, (Z est un peu duraille, mais j'y travaille).

Bon départ...
>Par contre j'ai bien regardé mais pas assez peut-être, je le branche où mon ventilateur pour la tête ?
Ca dépend de ta gen7, ils y a plusieurs gen7 certains prenant des ventilos etl a derniere non.
Ya plusieurs type de ventilo, ceux pour les entre-couches et ceux pour la tete (peut etre tu peux betement le brancher avec un potar sur ton alim?,
honnetement ca j'en sais rien j'en ai jamais mis).
>Et mes lectures de températures sont très hautes, 458°, demain je vérifie les soudures, mais j'ai regardé dans teacup et je ne sais où définir la >thermistance.
Dans le Teacup firmware il y a un fichier Thermistortable.h (ou un truc comme ca, c'est facile a reperer), c'est deja un bon commencement.
Apres tu trouveras sur internet une table relative a ton thermistor, ou alors tu la calculeras. cf [reprap.org]

>Voilà pour le moment c'est tout ce que je vois.
>Ah oui, vous suggérez quoi ? 1/16 ? ou 1/8 ?
Tout dépend de tes moteurs, si tu utilises des moteurs surdimensionnés 1/16 passera bien, si ils sont sous-dimensionné, tu sauteras peut etre des pas. fait attention, tu peux toujours passer en 1/16 et descendre si tu vois des couches successives qui se décale...

Honnêtement je m'en suis jamais sortis avec le Teacup firmware, je l'ai parfaitement configuré mais j'ai jamais trouvé des E_STEP_PER_MM qui m'ont permis de me connecter avec un host et faire une impression efficasse.

Par contre, je suis sous Repetier, c'est ultra facile a configurer et ca a marché quasi du premier coup^, mon je te conseille, apres tu fais ce que tu veux, d'autre plaiderons surement par Teacup, moi j'ai eu que des merdes avec eux.

Cdt,


Ghunt,

ヽ(´ー`)ノ

PLA needs you...

BlogBordélique

thingiverse
Re: deux ou trois questions sur la gen7 et teacup.
February 09, 2012 12:16AM
Merci.

ok, c'est un ventilo pour souffler sur l'extrudeur et le chariot, tout est en PLA et donc, je vais essayer de bloquer la chaleur qui pourrait remonter et ramollir smiling smiley, je vais le brancher en direct sur l'alim, j'ai regardé c'est la 1.3.1 donc pas de fan.

Je vais essayer repetier, je l'ai essayé sur ma prusa qui a un RAMPS 1.3 et c'est pas mal, mais je voulais essayer teacup avant, je vais changer ça cet aprem.

Je vais laisser en 1/16.
Re: deux ou trois questions sur la gen7 et teacup.
February 09, 2012 01:00AM
Il faut aussi savoir qu'avec la Gen7 la lecture de température n'est valide que quand l'alimentation tourne - par exemple pour tester je demande à lancer la chauffe à 30 °C, j'entends le ventilo de l'alim PC qui démarre et les températures affichées deviennent plausibles.


Most of my technical comments should be correct, but is THIS one ?
Anyway, as a rule of thumb, always double check what people write.
Salut,

j'en suis au même stade avec la gen7 sur la mendel.
Je n'ai donc pas réglé tous mes problèmes mais je te livre dans ton texte les pistes sur lesquelles je travaille.

pomalin Wrote:
-------------------------------------------------------

> Par contre j'ai bien regardé mais pas assez
> peut-être, je le branche où mon ventilateur pour
> la tête ?
A ma demande, Markus Hitter, le concepteur de la carte, m'a envoyé une carte d'extension pour le ventilo.
Là tout de suite, je n'est pas de site où la poster mais si cela t'intéresse on peut trouver un moyen (email ou autre).
C'est conçu comme le coin des résistances (alim 12V, MOFSET, r1,r2,, led, etc...)
Je compte ensuite connecter le câble de signal au pin PD6 (pin PWM disponible) de l'ATMEGA via le connecteur MISC HEADER.
et j'ai configuré le config.h comme suit (je me suis appuyé sur les indications du fichier).

DEFINE_HEATER(fan, PD6)
#define HEATER_FAN HEATER_fan

Je n'ai pas testé la solution puisque le ventilo n'est pas encore monté mais je pars sur l'idée que cela suffit à démarrer le ventilo à partir du Gcode.

> Et mes lectures de températures sont très
> hautes, 458°, demain je vérifie les soudures,
> mais j'ai regardé dans teacup et je ne sais où
> définir la thermistance.

Merci à DeuxVis pour sa réponse, j'en étais là.

Cordialement,
Max
Re: deux ou trois questions sur la gen7 et teacup.
February 09, 2012 04:15AM
Quote

Honnêtement je m'en suis jamais sortis avec le Teacup firmware, je l'ai parfaitement configuré mais j'ai jamais trouvé des E_STEP_PER_MM qui m'ont permis de me connecter avec un host et faire une impression efficace.

En fait pour Teacup, tout est en Step per Meter, il faut rajouter 000. Mais même en mettant les valeurs calculées au petit oignons, c'est vrai que ça ne marche pas bien. Par ajustements successifs, j'ai du diviser par plus de 10 avant d'avoir quelque chose d'à peu près correct ... et encore !

edit : pour infos les valeurs que j'ai mis avec une prusa V2 et un wade's
#define STEPS_PER_M_X 80000
#define STEPS_PER_M_Y 80000
#define STEPS_PER_M_Z 1280000
#define STEPS_PER_M_E 2100

tout les axes sont en 1/16 sauf le Z qui est en 1/8

Par contre chez moi la rétractation (avec repetier et slic3r) ne fonctionne pas franchement. Mais ça doit etre un autre problème.

Edited 2 time(s). Last edit at 02/09/2012 05:06AM by raoullevert.
Re: deux ou trois questions sur la gen7 et teacup.
February 09, 2012 05:47AM
Oui au Step per meter dans la nouvelle version du Teacup.

raoullevert Wrote:
-------------------------------------------------------

> tout les axes sont en 1/16 sauf le Z qui est en
> 1/8
>
> Par contre chez moi la rétractation (avec
> repetier et slic3r) ne fonctionne pas franchement.
> Mais ça doit etre un autre problème.

Pour la rétraction si je me souviens bien, il y a 2 façon de l'integrer.
-Dans l'host (dans repetier avec slic3r c'est dans la configuration de slic3r -pour moi ca marche-)
-Dans le firmware, dans la nouvelle version (a moins que mes souvenirs defaillent) il y a une solution de retraction en dur dans le config.h.

Honnetement sur le Teacup, XYZ + heater + temperatures marchait bien, c'est pas compliqué normalement (je peux passer les passages de mon config.h des que je rentre chez moi si vous voulez)


Ghunt,

ヽ(´ー`)ノ

PLA needs you...

BlogBordélique

thingiverse
Re: deux ou trois questions sur la gen7 et teacup.
February 09, 2012 06:30AM
Effectivement il y a un retractation 'en dur' ... mais ça ne fonctionne pas non plus.


Pour Teacup, il y a un script python pour générer la table de température.
pour la gen 7 : R1=0 R2=4700
Pour moi la température est à 170 affichée pour en gros 180.

Honnetement je préfère un firmware repetier, mais j'ai des soucis de communication avec la nouvelle version.
Re: deux ou trois questions sur la gen7 et teacup.
February 09, 2012 09:45AM
raoullevert Wrote:
-------------------------------------------------------
> Effectivement il y a un retractation 'en dur' ...
> mais ça ne fonctionne pas non plus.

Arf, j'ai pas testé
>
> Pour Teacup, il y a un script python pour
> générer la table de température.
> pour la gen 7 : R1=0 R2=4700
> Pour moi la température est à 170 affichée pour
> en gros 180.

C'est un bon début meme si c'est pas ca... T'as pas des tables spécifiées? Ils sortent d'ou tes thermistors, quels sont-ils?

> Honnetement je préfère un firmware repetier,
> mais j'ai des soucis de communication avec la
> nouvelle version.

Ok je vais poster ce que j'ai sous la main (je les ai sous la main maintenant).

Pour le Teacup:
voila en largeur ce que j'ai mis (ATTENTION: c'est peut etre pas la meilleure config):
C'etait pour la gen7 v1.2 mais ca devrait marcher pour la 1.3.1
#define	X_STEP_PIN						DIO19
#define	X_DIR_PIN							DIO18
#define	X_MIN_PIN							DIO7

#define	Y_STEP_PIN						DIO23
#define	Y_DIR_PIN							DIO22
#define	Y_MIN_PIN							DIO5

#define	Z_STEP_PIN						DIO26
#define	Z_DIR_PIN							DIO25
#define	Z_MIN_PIN							DIO1

#define	E_STEP_PIN						DIO28
#define	E_DIR_PIN							DIO27

define	PS_ON_PIN							DIO15

[..]
//                 name       type          pin		additional
DEFINE_TEMP_SENSOR(extruder,	TT_THERMISTOR,	AIO1_PIN,0)
DEFINE_TEMP_SENSOR(bed,	        TT_THERMISTOR,	AIO2_PIN,0)

[...]
//                 name       type          pin		additional 
DEFINE_TEMP_SENSOR(extruder,	TT_THERMISTOR,	AIO1_PIN,0) // j'ai des thermistor 100k de chez GRRF
DEFINE_TEMP_SENSOR(bed,	        TT_THERMISTOR,	AIO2_PIN,0)
[...]
DEFINE_HEATER(extruder,	PB4)
DEFINE_HEATER(bed,			PB3)
DEFINE_HEATER(fan,			PA0)

#define	HEATER_EXTRUDER HEATER_extruder
#define HEATER_BED HEATER_bed
#define HEATER_FAN HEATER_fan
[...]


Pour le repetier: pour la gen7 1.3.1 (testé et certifié winking smiley )
Dans Configuration.h :
Note: J'utilise le plugin gen7 pour arduino donné dans le zip de la gen7 et non celui de repetier et j'utilise arduino0023
[...]
#define MOTHERBOARD 7

/** \brief Number of steps for a 1mm move in x direction */
#define XAXIS_STEPS_PER_MM 64
/** \brief Number of steps for a 1mm move in y direction */
#define YAXIS_STEPS_PER_MM 80
/** \brief Number of steps for a 1mm move in z direction */
#define ZAXIS_STEPS_PER_MM 6400

/** Number of extruders. Maximum 2 extruder. */
#define NUM_EXTRUDER 1

[...]
#define EXT0_TEMPSENSOR_TYPE 1
// Position in analog input table below for reading temperatures or pin enabling SS for MAX6675
#define EXT0_TEMPSENSOR_PIN 1
[...]
#define HAVE_HEATED_BED true

#if HAVE_HEATED_BED==true
// Select type of your heated bed. It's the same as for EXT0_TEMPSENSOR_TYPE
// set to 0 if you don't have a heated bed
#define HEATED_BED_SENSOR_TYPE 1

[...]
#define BAUDRATE 115200 // /!\ COMMUNICATION
ATTENTION: sous Repetier host faut biensur mettre le meme Baudrate (c'est pas ca par default).
J'ai constaté qu'il fallait desfois:
- arreter repetierhost
- deconnecter le port USB
- hardreset sur la gen7
- attendre que le bootloader passe pour aller sur le soft (5s environ)
- rebrancher usb
- redémarrer repetier host et presser "connecter "

(il doit lire les temperatures au démarrage - mauvaise, puisque l'alim n'est pas allumé mais lire quand meme)

Dans le pin.h

[...]
  //extruder pins
    #define E_STEP_PIN      28     
    #define E_DIR_PIN       27     
    #define E_ENABLE_PIN    24     
    #define TEMP_0_PIN      PINA1
    #define TEMP_1_PIN      PINA2
    #define HEATER_0_PIN    3    
    #define HEATER_1_PIN    4    
[...]

Voila, ca devrait etre un point de départ.
Pour Teacup je certifie rien du tout si ce n'est que tout avait l'air de fonctionner sauf l'extrudeur impossible a calibrer
mais il y a de grande chances que cela soit a cause de l'host (repsnapper,reprap,replicatorG) et du STL2GCODE (surement skeinforge sous repsnapper). J'avais pas testé Slic3r a l'époque...

VOilou

Edited 5 time(s). Last edit at 02/09/2012 10:00AM by Ghunt.

Ghunt,

ヽ(´ー`)ノ

PLA needs you...

BlogBordélique

thingiverse
Re: deux ou trois questions sur la gen7 et teacup.
February 09, 2012 01:28PM
Alors, de retour à la maison, cette fois ci avec teacup, j'ai x,y,z calibrés, endstops ok, E aussi dans pronterface, mais lors de l'impression, pas de rétraction et des tas de plastique, trop trop trop.
Avec repetier, ben upload ok, connection ok ? (avec pronterface, il faut que je finisse de nettoyer ubuntu des trucs qui empèchent le repetier-host de démarrer), puis rien, sauf wait, wait, wait, wait, si j'essaye une commande pour lancer l'alim, j'ai ok 0, puis wait, wait, wait, wait........ Au passage, j'ai enlevé la gestion de l'eeprom, parceque je pense que c'est pour ça que je ne pouvais pas remettre teacup après repetier.
Ensuite avec teacup donc, si je slice avec sfact, ça démarre mais comme dis plus haut, trooooop de plastique par endroits, si je slice avec slic3r, ça reste bloqué sur waiting for temperature.

en gros, help smiling smiley
Re: deux ou trois questions sur la gen7 et teacup.
February 09, 2012 02:26PM
J'avais aussi trop trop trop de plastique avec teacup, jusqu'à ce que je trouve le paramètre : longueur d'extrusion absolue (en opposition à relative) à activer (fait une recherche sur "absolute" dans le fichier config.h, je ne me souviens pas exactement de la variable).


Most of my technical comments should be correct, but is THIS one ?
Anyway, as a rule of thumb, always double check what people write.
Re: deux ou trois questions sur la gen7 et teacup.
February 09, 2012 02:45PM
ok, je vais regarder ça demain, merci.
Re: deux ou trois questions sur la gen7 et teacup.
February 09, 2012 05:55PM
Genial, merci pour les infos !

Avec teacup et slic3r : aucun soucis. Teacup + Skeinforge : trooop de plastique. Ca doit donc venir de la configuration du slicer (absolu/relatif).

Je vais recompiler le repetier avec ton pin.h.
Merci.
Re: deux ou trois questions sur la gen7 et teacup.
February 10, 2012 02:18AM
Du coup je jeterais un coup d'oeil sur le teacup avec la commande absolute que j'avais pas vu, c'etait surement ca mon probleme sous Teacup.

Merci


Ghunt,

ヽ(´ー`)ノ

PLA needs you...

BlogBordélique

thingiverse
Re: deux ou trois questions sur la gen7 et teacup.
February 10, 2012 03:19AM
bon, j'ai fait un test chez moi, je ne serais à l'école que cet aprem, au cas où il y aurait quelqu'un avec un ordi sous ubuntu 11.10 pour repetier host il faut installer mono sad smiley et mesa-utils, sinon, pas de repetier host.
Re: deux ou trois questions sur la gen7 et teacup.
February 10, 2012 03:24AM
Pour teacup, j'ai retrouvé la variable, c'est E_ABSOLUTE à dé-commenter.


Most of my technical comments should be correct, but is THIS one ?
Anyway, as a rule of thumb, always double check what people write.
Re: deux ou trois questions sur la gen7 et teacup.
February 10, 2012 08:43AM
Très grand merci à DeuxVis, tout est impeccable avec teacup maintenant, je verrais pour repetier peut-être la semaine prochaine, mais voilà, la machine fonctionne, perfect......
Re: deux ou trois questions sur la gen7 et teacup.
February 10, 2012 09:23AM
et hop, voilà la bête et ses toutes premières impressions, de gauche à droite impression une un "cube" 20x20x2 mm, nickel, deuxième un rond, et une poulie crantée à chevron pour l'extrudeur wade, nickel je vous dit smiling smiley
Attachments:
open | download - P1080994.png (419.6 KB)
open | download - 2012-02-10 16.16.15.png (496.3 KB)
Re: deux ou trois questions sur la gen7 et teacup.
February 10, 2012 11:48AM
Ca t' embetes de poster les paramètres que tu as mis dans le teacup ? Tu as un Wade avec la vis de 8 non ?
J'ai activer l'option E_Absolute, et la retractation fonctionne maintenant. Ca rétracte même tellement bien que j'ai plus rien qui sort :-)
Par contre, ça influe apparemment sur tous les réglages ! Je suis paumé avec tout ce que j'ai modifié !
Re: deux ou trois questions sur la gen7 et teacup.
February 10, 2012 12:24PM
aucun probleme pour te passer les paramètres, sauf que tout est à l'école, et je n'y retourne pas avant mercredi normalement, sauf si j'y passe mardi, mais ce serait surprenant.
Re: deux ou trois questions sur la gen7 et teacup.
February 10, 2012 01:36PM
pas de probleme. Je suis pas a une journée près !
j'ai réussis a faire des impressions de cube propres mais c'est a peu près tout. Je profite de ton expérience !
Re: deux ou trois questions sur la gen7 et teacup.
February 11, 2012 12:36PM
En fait je ne comprenais pas pourquoi la reprap n'extrudait pas de plastique : j'étais tout bêtement resté en 'relatif' dans slic3r alors que le firmware étais avec 'absolute' activé. Maintenant avec les valeurs théoriques ça fonctionne bien (teacup). J'ai aussi baissé l'accélération max, pour avoir des mouvements plus fluides : Ca change tout !
Les moteurs chantent l'extrusion est quasi parfaite.

Bref que du bonheur ! Merci beaucoup a tous pour les conseils (encore une fois judicieux).
Re: deux ou trois questions sur la gen7 et teacup.
February 12, 2012 06:04AM
Ah ben cool alors...
Re: deux ou trois questions sur la gen7 et teacup.
February 12, 2012 06:40AM
J'ai imprimé aussi la poulie a chevrons. C'est plutôt satisfaisant, le seul soucis vient (a mon avis) du teacup qui extrapole les cercles avec des séries de lignes droites; du coup il y a des petits 'crans' au niveau des cercles.
Mais c'est vraiment du mini détail. Pour la grosse roue à chevrons par contre, qui est en court d'impression, ça a l'air quasi parfait (j'ai baissé un poil la température d'extrusion ...)

@Pomalin : Pour faire ta poulie, tu as mis ton petit ventilo ? Je vais me faire un montage du genre pour les tout petits détails.

Ca fait vraiment plaisir d'imprimer ses premières pièces 'propres'.
Re: deux ou trois questions sur la gen7 et teacup.
February 12, 2012 07:32AM
Non, pas de ventilo encore sur cette machine là, comme il faut que je le branche en direct puisqu'il n'y a pas de branchement pour sur la gen7, par contre pour les trucs à petits détails, pour laisser le temps de refroidir si on a pas de ventilo on peut en imprimer plusieurs, comme ça le temps que ça fasse le rang de la deuxième pièce le rang de la première à le temps de refroidir assez.
Re: deux ou trois questions sur la gen7 et teacup.
February 12, 2012 07:50AM
C'est pas bête d'en imprimer plusieurs.
Je vais me faire un support ventilo quand même.
Re: deux ou trois questions sur la gen7 et teacup.
February 12, 2012 07:54AM
Oui j'ai pris la chariot de gregfrost avec le support ventilo, comme ça je l'ai posé, pour le branchement je vais le faire en direct mais avec un interrupteur pour le déclencher à la demande.
Re: deux ou trois questions sur la gen7 et teacup.
February 12, 2012 02:36PM
En ce moment il suffit d'ouvrir la fenêtre pour avoir un refroidissement très efficace *glagla*.


Most of my technical comments should be correct, but is THIS one ?
Anyway, as a rule of thumb, always double check what people write.
Re: deux ou trois questions sur la gen7 et teacup.
February 12, 2012 11:07PM
Re: deux ou trois questions sur la gen7 et teacup.
February 14, 2012 10:31AM
A propos de teacup : les cercles ne sont pas circulaires :-) comme avec marlin ou repetier. En fait ça me fait des sortes de vaguelettes. Ca fait ça chez tout le monde ou ça vient du teacup ?

Je mets une photo histoire d'illustrer mes propos. En fait ces sont les 'vagues' dans le plan (x/y).
Si seulement repetier voulait fonctionner !
Attachments:
open | download - petite roue chevrons.jpg (185.3 KB)
open | download - grosse roue chevrons.jpg (236.1 KB)
Sorry, only registered users may post in this forum.

Click here to login