Welcome! Log In Create A New Profile

Advanced

TMC2130 Stallguard

Posted by S1CAR1US 
TMC2130 Stallguard
February 06, 2018 03:03PM
Hi all, I have just installed some tmc 2130s and not having much luck. Can someone who has experience give me some feedback on this log file maybe? Right now I am getting no movement but I was originally out of only one axsis. I followed the Toms guide...

14:55:17.337 : N79 M122*28
14:55:17.379 : X	Y
14:55:17.379 : Enabled		false	true
14:55:17.379 : Set current	0	0
14:55:17.379 : RMS current	1767	979
14:55:17.379 : MAX current	2491	1380
14:55:17.379 : Run current	31/31	31/31
14:55:17.379 : Hold current	12/31	12/31
14:55:17.379 : CS actual		0/31	31/31
14:55:17.379 : PWM scale	0	255
14:55:17.379 : vsense		0=.325	1=.18
14:55:17.379 : stealthChop	true	true
14:55:17.379 : msteps		256	0
14:55:17.379 : tstep		1048575	4294967295
14:55:17.379 : pwm
14:55:17.379 : threshold		0	0
14:55:17.379 : [mm/s]		-	-
14:55:17.379 : OT prewarn	false	true
14:55:17.379 : OT prewarn has
14:55:17.379 : been triggered	false	false
14:55:17.379 : off time		0	15
14:55:17.379 : blank time	16	54
14:55:17.379 : hysterisis
14:55:17.379 : -end		-3	12
14:55:17.379 : -start		1	8
14:55:17.379 : Stallguard thrs	50	0
14:55:17.379 : DRVSTATUS	X	Y
14:55:17.379 : stallguard			X
14:55:17.379 : sg_result		0	1023
14:55:17.379 : fsactive			X
14:55:17.379 : stst		X	X
14:55:17.379 : olb			X
14:55:17.379 : ola			X
14:55:17.379 : s2gb			X
14:55:17.379 : s2ga			X
14:55:17.379 : otpw			X
14:55:17.379 : ot			X
14:55:17.379 : Driver registers:
14:55:17.379 : X = 0x80:00:00:00
14:55:17.379 : Y = 0xFF:FF:FF:FF
14:56:03.993 : N80 G91*41
14:56:03.993 : N81 G1 Y1 F4800*51
14:56:03.993 : N82 G90*42

Also, since installing, I am getting what appears to me to be noise on my thermistor readings...


Edited 1 time(s). Last edit at 02/06/2018 03:13PM by S1CAR1US.
Re: TMC2130 Stallguard
February 07, 2018 09:02PM
have you looked here [github.com] and arduino library [github.com] another site [hackaday.com] what the first link is the marlin setup the second is an arduino library file and info and the third site is detailed discussion of the driver. This driver is a very complex unit with many variables to setup and at some point recommend a scope to setup. It appears you only have y axis enabled. I have not used this driver but am interested to know more about it. Do you have the SPI hooked up.
Sorry, only registered users may post in this forum.

Click here to login