Welcome! Log In Create A New Profile

Advanced

Upgraded from Ramps to Duet Wifi and having issues with z probe?

Posted by Kevin37 
Upgraded from Ramps to Duet Wifi and having issues with z probe?
November 09, 2017 07:20PM
I just recently upgraded from Ramps to Duet Wifi with 1.19.3 version Firmware and Web interface and all is working well except when I home all axis the bed crashes into the hotend. I am using a custom corexy printer that I designed from 1 3/4 aluminum extrusions 300 x 300 x 500. I am using a PNP inductive sensor hooked up to the z-probe-in port with a LM7805 to lower the voltage, this has worked for me on the Ramps and the MKS Sbase smoothie board but is giving me issues now. When I disconnect the probe the bed will go down about 5 mm and stay there when I home all the axis. When plugged in, it will raise to the hotend like it supposed to, but it will not stop when the sensor triggers. I hooked it up to Ponterface and sent the M119 code and it said this SENDING:M119 Endstops - X: not stopped, Y: not stopped, Z: not stopped, Z probe: at min stop

I have been messing with this for the past three days with no change and I have no clue what I am doing wrong and I am very new to RepRap and Duet, in short this is driving me crazy!confused smiley If anyone could help me with this it would be greatly appreciated. I have included my config.g in the attachments if this will help. Thank you in advance.
Attachments:
open | download - config.g (4.3 KB)
Re: Upgraded from Ramps to Duet Wifi and having issues with z probe?
November 09, 2017 11:36PM
M574 Z1 S0
What does the label of your inductive probe say? NO or NC? I'm not sure what the 7805 does, when not powered?

M558 P5 X0 Y0 Z0
This line says you are not using a z-probe. Read more about it here or in the DuetWifi Wiki.

M558 P5 X0 Y0 Z1 (add I1 or I0 for normally open/ normally closed switch )

Edited 3 time(s). Last edit at 11/09/2017 11:45PM by o_lampe.
Re: Upgraded from Ramps to Duet Wifi and having issues with z probe?
November 10, 2017 12:16AM
The recommended way to connect a PNP Z probe is described at [www.duet3d.com]. The Duet wants a 3V signal, not 5V.

Check that you have your homez.g and the Z homing section of homeall.g set up correctly for homing with a Z probe. See [www.duet3d.com].


Delta printer calibration calculator, mini IR Z probe, and colour touch screen control panel: [escher3d.com]

Large delta printer, and other 3D printer blog postings: [miscsolutions.wordpress.com]

Disclosure: I have a financial interest in sales of the Panel Due, Mini IR height sensor, and Duet WiFi/Duet Ethernet [www.duet3d.com].
Re: Upgraded from Ramps to Duet Wifi and having issues with z probe?
November 10, 2017 09:14AM
Wouldn't the inductive sensors be connected to E0 STP instead of the Z-Probe pins because they're not analog signals and are either on or off?
Re: Upgraded from Ramps to Duet Wifi and having issues with z probe?
November 10, 2017 01:00PM
The Z probe input can be configured for both analogue and digital output sensors. With a PNP output sensor, the high impedance input of the Z probe connector is preferred.


Delta printer calibration calculator, mini IR Z probe, and colour touch screen control panel: [escher3d.com]

Large delta printer, and other 3D printer blog postings: [miscsolutions.wordpress.com]

Disclosure: I have a financial interest in sales of the Panel Due, Mini IR height sensor, and Duet WiFi/Duet Ethernet [www.duet3d.com].
Re: Upgraded from Ramps to Duet Wifi and having issues with z probe?
November 13, 2017 10:27AM
Thank you guys for responding so quick, sorry for the late reply I have been really busy and I haven't touch the printer since the day I made this post. I also have a hot end mounted piezo from precision piezo comming in the mail today. So if I have any issues with getting it to work I will let you guys know, its always hard moving to a new platform and learning how to do everything again. I just need to study up! Thanks again
Sorry, only registered users may post in this forum.

Click here to login