Welcome! Log In Create A New Profile

Advanced

Help Configuring Large-Screen LCD

Posted by perseveranze 
Help Configuring Large-Screen LCD
November 01, 2017 05:32PM
Hello all.

I'm running a Hictop Prusa printer. I'm currently in the middle of moving all electronics off the printer and into a control box for easier handling. I want to go from the small screen that comes with the printer to the larger screen. When I plug it in EXP1/EXP1 and EXP2/EXP2, I get a blinking light and an audible beep but no screen. When I plug it in EXP1/EXP2 to EXP2/EXP1, light comes on solid but so does the audible. Any ideas as to what is going on?

Thanks for your time.
Re: Help Configuring Large-Screen LCD
November 01, 2017 06:42PM
small screen? do you mean a 2004 char display ?

Large screen? do you mean a 12864 glcd?

The two are not plug in and go... one is dot matrix display of 128x64 pixels the other is a character display that can display in a 20 char by 4 lines.

You need to reconfigure your firmware for the new type of display.

Also there are issues with some suppliers, they wired the plugs on the back of the screens different so you have to turn the plugs around 180 degrees, which is tricky as they are keyed.
Re: Help Configuring Large-Screen LCD
November 01, 2017 07:09PM
The small screen is the standard issue screen, sounds like 20x4. The large is the 12864. I figured I'd need to re-up my firmware. I didn't know that the wiring is backwards for the screen. I'll have to look into that. Any advice on reconfiguring the firmware?
Re: Help Configuring Large-Screen LCD
November 01, 2017 08:08PM
you really need to know what your new screen is to be able to update your firmware, most are REPRAP_DISCOUNT_FULL_GRAPHIC_SMART_CONTROLLER clones

Installation: In "Configuration.h”

Change “//#define REPRAP_DISCOUNT_FULL_GRAPHIC_SMART_CONTROLLER” (just remove the // at the beginning)

==> REMEMBER TO INSTALL U8glib to your ARDUINO library folder: [code.google.com]

find your old display setting and comment it out
Its probably #define REPRAP_DISCOUNT_SMART_CONTROLLER so you need to put // in front of that line

Upload the firmware, power off the Arduino, connect the panel, reapply power, and everything should work.



If it doesn't then you may have to turn your cables around

Edited 1 time(s). Last edit at 11/01/2017 08:08PM by Dust.
Sorry, only registered users may post in this forum.

Click here to login