Welcome! Log In Create A New Profile

Advanced

Endstops issues

Posted by brazik 
Endstops issues
October 08, 2017 08:50AM
Hi,

I've got problem with my homemade printer. There is an issue with endstops which are triggered when they don't suppose to be. I tried to take only one cable and connect each endstop separetely after doing this i recognized that X endstop works great but Y and Z endstops are always triggered. Sometimes when cable was connected to Z axis endstop and pressed, M119 return Y as open... Than I used only one endstop and connect it to all X Y Z slots on ramp and there was the same problem when X endstop worked perfectly so I think there is problem with ramps or mega bard... Also when printer is homing Y axis only bump but doesnt stay on pressed endstop and its few centometers away... Once when printer was printing the voltage stabilizer on mega burned I dont if there is any connection with this endstops issue... Also I changed on ramps mosfet for hotbed, but i dont think that there is any connection...

Thank u for any help I am quite new in this porblematics smiling smiley
Re: Endstops issues
October 08, 2017 10:27AM
which endstop you using ? you using marlin ?and you sure the headers are on the right Pins and observing polarity of the headers

with marlin have a peek around line 489 in the config.h file

// Mechanical endstop with COM to ground and NC to Signal uses "false" here (most common setup).
#define X_MIN_ENDSTOP_INVERTING false // set to true to invert the logic of the endstop.
#define Y_MIN_ENDSTOP_INVERTING false // set to true to invert the logic of the endstop.
#define Z_MIN_ENDSTOP_INVERTING false // set to true to invert the logic of the endstop.
#define X_MAX_ENDSTOP_INVERTING false // set to true to invert the logic of the endstop.
#define Y_MAX_ENDSTOP_INVERTING false // set to true to invert the logic of the endstop.
#define Z_MAX_ENDSTOP_INVERTING false // set to true to invert the logic of the endstop.
#define Z_MIN_PROBE_ENDSTOP_INVERTING false // set to true to invert the logic of the probe.

what happens if you swap Z to true.
Re: Endstops issues
October 08, 2017 10:31AM
Hello and thank you for help smiling smiley

It stays opened all time and sometimes is Y triggered or opened... I tried 4 different cables so I dont think that problem is there sad smiley I think there are some hardware troubles...
Re: Endstops issues
October 08, 2017 01:32PM
Most likely you have damaged IO pins....

Edited 1 time(s). Last edit at 10/08/2017 01:34PM by Dust.
Sorry, only registered users may post in this forum.

Click here to login