Welcome! Log In Create A New Profile

Advanced

3D Touch / BL Touch not working

Posted by RepMike 
3D Touch / BL Touch not working
October 06, 2017 01:52AM
Hello, I've got a Ramps 1.4 Board on which I'm trying to get the 3D touch sensor from Geeetech running. It does nothing. Can you help me?
Here is my Configuration.h: [pastebin.com]

If I manually push the pin up, the red LED lights up, manually down: LED off. I have connected 5V to VCC by a jumper and I've connected the cables as in the documentation, I am sure that the cables are as they are supposed to be, so switched cables/colors. There was no shorting cables, so everything should be intact.

If I issue the test commands like M280 P0 S120 or M280 P0 S90 or M280 P0 S10 or M280 P0 S160, there is absolutely no reaction.

While trying the deploy/stow commands, I made sure that I'm over Z_CLEARANCE_DEPLOY_PROBE.
Marlin Version 1.1.4.

I would be grateful for any hint.
Re: 3D Touch / BL Touch not working
October 06, 2017 04:10AM
Please post a clear picture of the ramps and where you plugged the wires in.... (just have to check)

the code you posted has "#define Z_SERVO_ANGLES {90,10} // Z Axis Extend and Retract angles" but the documents say 10,90
your code also says #define NUM_SERVOS 3 where as the docs say #define NUM_SERVOS 1


Other than that Look good.

Edited 2 time(s). Last edit at 10/06/2017 04:15AM by Dust.
Re: 3D Touch / BL Touch not working
October 06, 2017 11:52AM
Thank you for your reply and for taking your time to look through Configuration.h.
Here's the relevant parts on the Board:

I hope it's fine that I only took a picture of those parts, the rest is just a ball of cable wool. smiling smiley
I took Dupont Wires of the same color in order to extend the wires of the sensor and I've measured the continuity of the current from all connector ends.

The 10,90 / 90,10 results from trying all alternatives, I've tried 10,90 before without success.
I've also tried Servos 1 instead of 3, because in a Forum someone mentioned that it only worked with a 3, which seemed strange to me as well, but hey, when it's stormy on the high seas, any port is welcome.

(Sorry if people see me crossposting, the moderator in the respective Geeetech forum took his time to approve my posting so I thought he wouldn't do so and hence I posted here, but in the end he did approve. I know it sometimes annoys people, but it was in good faith that my post wouldn't go through.)
Sorry, only registered users may post in this forum.

Click here to login