Welcome! Log In Create A New Profile

Advanced

Connecting Mendel to Pronterface issues (Linux ARM)

Posted by l51r8 
Connecting Mendel to Pronterface issues (Linux ARM)
August 23, 2012 11:20AM
Hi All,

I'm trying to control a Mendel w/ Gen6 electronics with a Efika MX Smartbook (arm cortex a8) running an Ubuntu/maverick 10.10 based distro.

I've had it running fine on my windows laptop using Repsnapper. But I am completely lost when it comes to Linux!

I had no luck running repsnapper, reprap host, or repetier! I have managed to successfully install Pronterface and Slicr. But I cannot get Pronterface to connect to the printer.

I have looked up many tutorials, downloaded tons of libraries, I think I've installed FiveD gcode interpreter for firmware, and also ran some commands for an FTDI file...but honestly, I'm lost! I don't kn
Re: Connecting Mendel to Pronterface issues (Linux ARM)
August 23, 2012 11:23AM
Sorry, this comp is a little buggy, and sent my post early!

If someone could please tell me the detailed steps to get the printer running on linux, or at least point me toward a COMPLETE set up guide, I would be forever grateful. And again...I know NOTHING about linux!

Thanks in advance,
Deb
Re: Connecting Mendel to Pronterface issues (Linux ARM)
August 24, 2012 03:34AM
Hi Deb,
I haven't played around with an arm based machine, but it should be the same as the linux box I'm currently running on.

I might also get a bit technical, so bear with me.

First we need to check if you laptop can even see the board in the first place.
For this I need you to start up a terminal of some sort, this will make things go much quicker.
Run the command: "lsusb" (no quotes) this looks at all the devices connected to the usb and lists their properties.
You should see the list change after plugging and unplugging the board from usb, the new device should be called FTDI or something similar.
If there isn't, there might be something wrong with the usb port you are using.

If your computer does see the board, you might not have rights to communicate over serial.
Using the same terminal, you should execute the command "sudo usermod -a -G dialout "
Replace with our username on that machine. This should allow you to communicate over the serial to usb adapter that repraps use.
After you reboot (I have to do this on my machine, not sure about others), you should be able to connect with the board.
Re: Connecting Mendel to Pronterface issues (Linux ARM)
August 27, 2012 05:28AM
Thank you so much. Got it up and running!
Hello Euhedral,

I'm having a similar issue to Deb, I am unable to connect to my Mendel. I have checked that I can see the board, or at least I believe so, here is a print out:

Bus 001 Device 002: ID 1410:a014 Novatel Wireless
Bus 001 Device 003: ID 04f2:b205 Chicony Electronics Co., Ltd
Bus 004 Device 002: ID 0403:6001 Future Technology Devices International, Ltd FT232 USB-Serial (UART) IC
Bus 005 Device 002: ID 0cf3:3005 Atheros Communications, Inc. AR3011 Bluetooth
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

I would assume that its the "Bus 004 Device 002: ID 0403:6001 Future Technology Devices International, Ltd FT232 USB-Serial (UART) IC"

I have also made sure that my user is part of the dailout group. Here is a printout:

user@ChrUbuntu:~$ groups user
user : user adm dialout cdrom sudo dip plugdev lpadmin sambashare

Am I missing anything that you might know of, or something that I can try. I simply cannot connect to my printer using this computer. I'm running the latest version of Ubuntu.
Re: Connecting Mendel to Pronterface issues (Linux ARM)
October 06, 2012 12:15AM
Hey Kit,
A few questions;
1: Can you connect if you run pronterface as root?
(Terminal -> navigate to pronterface directory -> sudo ./pronterface.py)
2: Have you programmed some variant of the reprap firmware to your board?
(Might require arduino IDE)
I just tried running pronterface as root.

Got this in the output after trying to connect:

Connecting...
Traceback (most recent call last):
File "./pronterface.py", line 1567, in connect
self.p.connect(port,baud)
File "/home/user/Documents/3DModeling/Printer-ReprapPro/printcore.py", line 76, in connect
self.printer=Serial(self.port,self.baud,timeout=5)
File "/usr/lib/python2.7/dist-packages/serial/serialutil.py", line 260, in __init__
self.open()
File "/usr/lib/python2.7/dist-packages/serial/serialposix.py", line 280, in open
self._reconfigurePort()
File "/usr/lib/python2.7/dist-packages/serial/serialposix.py", line 413, in _reconfigurePort
set_special_baudrate(self, custom_baud)
File "/usr/lib/python2.7/dist-packages/serial/serialposix.py", line 47, in set_special_baudrate
FCNTL.ioctl(port.fd, TERMIOS.TIOCGSERIAL, buf)
IOError: [Errno 22] Invalid argument

I am using the board which is supplied by Reprappro. I have had it previously running on a windows machine just fine and figured I'd use an older chomebook I've converted to Ubuntu as a dedicated printing computer.

The board is a Melzi V2.0, however I'm not sure of the firmware it's flashed with. I've not checked.
Re: Connecting Mendel to Pronterface issues (Linux ARM)
October 07, 2012 01:47AM
Does ftdi driver load and creates tty device? There should show up something similar in dmesg output:

usb 3-2: new full-speed USB device number 2 using uhci_hcd
usbcore: registered new interface driver usbserial
usbserial: USB Serial Driver core
USB Serial support registered for pl2303
pl2303 3-2:1.0: pl2303 converter detected
usb 3-2: pl2303 converter now attached to ttyUSB0
usbcore: registered new interface driver pl2303
pl2303: Prolific PL2303 USB to serial adaptor driver
I'm not really all that familiar with linux so here is the entire dmesg output. I browsed it but felt a little overwhelmed.

)
[    0.805739] pnp 00:01: [io  0x164e-0x164f]
[    0.805747] pnp 00:01: [io  0x0061]
[    0.805752] pnp 00:01: [io  0x0070]
[    0.805758] pnp 00:01: [io  0x0080]
[    0.805763] pnp 00:01: [io  0x0092]
[    0.805769] pnp 00:01: [io  0x00b2-0x00b3]
[    0.805774] pnp 00:01: [io  0x0063]
[    0.805780] pnp 00:01: [io  0x0065]
[    0.805785] pnp 00:01: [io  0x0067]
[    0.805791] pnp 00:01: [io  0x0600-0x060f]
[    0.805797] pnp 00:01: [io  0x0610]
[    0.805802] pnp 00:01: [io  0x0800-0x080f]
[    0.805808] pnp 00:01: [io  0x0810-0x0817]
[    0.805814] pnp 00:01: [io  0x0400-0x047f]
[    0.805819] pnp 00:01: [io  0x0500-0x053f]
[    0.805825] pnp 00:01: [io  0x0700-0x0701]
[    0.805832] pnp 00:01: [mem 0xe0000000-0xefffffff]
[    0.805838] pnp 00:01: [mem 0xfed1c000-0xfed1ffff]
[    0.805844] pnp 00:01: [mem 0xfed14000-0xfed17fff]
[    0.805850] pnp 00:01: [mem 0xfed18000-0xfed18fff]
[    0.805856] pnp 00:01: [mem 0xfed19000-0xfed19fff]
[    0.805862] pnp 00:01: [mem 0xfec00000-0xfec00fff]
[    0.805868] pnp 00:01: [mem 0xfee00000-0xfee00fff]
[    0.805899] pnp 00:01: disabling [io  0x164e-0x164f] because it overlaps 0000:00:1c.0 BAR 7 [io  0x1000-0x1fff]
[    0.806057] system 00:01: [io  0x0600-0x060f] has been reserved
[    0.806072] system 00:01: [io  0x0610] has been reserved
[    0.806084] system 00:01: [io  0x0800-0x080f] has been reserved
[    0.806097] system 00:01: [io  0x0810-0x0817] has been reserved
[    0.806109] system 00:01: [io  0x0400-0x047f] has been reserved
[    0.806121] system 00:01: [io  0x0500-0x053f] has been reserved
[    0.806134] system 00:01: [io  0x0700-0x0701] has been reserved
[    0.806149] system 00:01: [mem 0xe0000000-0xefffffff] has been reserved
[    0.806162] system 00:01: [mem 0xfed1c000-0xfed1ffff] has been reserved
[    0.806175] system 00:01: [mem 0xfed14000-0xfed17fff] has been reserved
[    0.806189] system 00:01: [mem 0xfed18000-0xfed18fff] has been reserved
[    0.806202] system 00:01: [mem 0xfed19000-0xfed19fff] has been reserved
[    0.806215] system 00:01: [mem 0xfec00000-0xfec00fff] could not be reserved
[    0.806229] system 00:01: [mem 0xfee00000-0xfee00fff] has been reserved
[    0.806245] system 00:01: Plug and Play ACPI device, IDs PNP0c02 (active)
[    0.806279] pnp 00:02: [io  0x0000-0x001f]
[    0.806285] pnp 00:02: [io  0x0081-0x0091]
[    0.806291] pnp 00:02: [io  0x0093-0x009f]
[    0.806297] pnp 00:02: [io  0x00c0-0x00df]
[    0.806304] pnp 00:02: [dma 4]
[    0.806381] pnp 00:02: Plug and Play ACPI device, IDs PNP0200 (active)
[    0.806455] pnp 00:03: [io  0x0070-0x0077]
[    0.806529] pnp 00:03: Plug and Play ACPI device, IDs PNP0b00 (active)
[    0.806720] pnp 00:04: [irq 0 disabled]
[    0.806742] pnp 00:04: [irq 8]
[    0.806749] pnp 00:04: [mem 0xfed00000-0xfed003ff]
[    0.806824] pnp 00:04: Plug and Play ACPI device, IDs PNP0103 (active)
[    0.806861] pnp 00:05: [io  0x00f0]
[    0.806874] pnp 00:05: [irq 13]
[    0.806952] pnp 00:05: Plug and Play ACPI device, IDs PNP0c04 (active)
[    0.806987] pnp 00:06: [mem 0xff800000-0xffffffff]
[    0.807087] pnp 00:06: Plug and Play ACPI device, IDs INT0800 (active)
[    0.807149] pnp 00:07: [io  0x0060]
[    0.807155] pnp 00:07: [io  0x0064]
[    0.807170] pnp 00:07: [irq 1]
[    0.807251] pnp 00:07: Plug and Play ACPI device, IDs PNP0303 (active)
[    0.807317] pnp 00:08: [irq 12]
[    0.807398] pnp 00:08: Plug and Play ACPI device, IDs AUI1700 SYN1e00 SYN0002 PNP0f13 (active)
[    0.807586] pnp: PnP ACPI: found 9 devices
[    0.807598] ACPI: ACPI bus type pnp unregistered
[    0.819028] pci 0000:00:1c.0: PCI bridge to [bus 01-01]
[    0.819049] pci 0000:00:1c.0:   bridge window [io  0x1000-0x1fff]
[    0.819067] pci 0000:00:1c.0:   bridge window [mem 0x91000000-0x91ffffff]
[    0.819083] pci 0000:00:1c.0:   bridge window [mem 0x90000000-0x90ffffff 64bit pref]
[    0.819104] pci 0000:00:1e.0: PCI bridge to [bus 02-02]
[    0.819179] pci 0000:00:1e.0: setting latency timer to 64
[    0.819190] pci_bus 0000:00: resource 4 [io  0x0000-0x0cf7]
[    0.819197] pci_bus 0000:00: resource 5 [io  0x0d00-0xffff]
[    0.819203] pci_bus 0000:00: resource 6 [mem 0x000a0000-0x000bffff]
[    0.819210] pci_bus 0000:00: resource 7 [mem 0x80000000-0xfebfffff]
[    0.819217] pci_bus 0000:01: resource 0 [io  0x1000-0x1fff]
[    0.819224] pci_bus 0000:01: resource 1 [mem 0x91000000-0x91ffffff]
[    0.819231] pci_bus 0000:01: resource 2 [mem 0x90000000-0x90ffffff 64bit pref]
[    0.819239] pci_bus 0000:02: resource 4 [io  0x0000-0x0cf7]
[    0.819246] pci_bus 0000:02: resource 5 [io  0x0d00-0xffff]
[    0.819253] pci_bus 0000:02: resource 6 [mem 0x000a0000-0x000bffff]
[    0.819259] pci_bus 0000:02: resource 7 [mem 0x80000000-0xfebfffff]
[    0.819362] NET: Registered protocol family 2
[    0.819487] IP route cache hash table entries: 65536 (order: 7, 524288 bytes)
[    0.820459] TCP established hash table entries: 262144 (order: 10, 4194304 bytes)
[    0.823589] TCP bind hash table entries: 65536 (order: 9, 2097152 bytes)
[    0.825168] TCP: Hash tables configured (established 262144 bind 65536)
[    0.825188] TCP: reno registered
[    0.825224] UDP hash table entries: 1024 (order: 4, 98304 bytes)
[    0.825310] UDP-Lite hash table entries: 1024 (order: 4, 98304 bytes)
[    0.825603] NET: Registered protocol family 1
[    0.825655] pci 0000:00:02.0: Boot video device
[    0.825932] PCI: CLS 64 bytes, default 64
[    0.826322] Simple Boot Flag at 0x44 set to 0x1
[    0.827293] microcode: CPU0 sig=0x106ca, pf=0x4, revision=0x107
[    0.827324] microcode: CPU1 sig=0x106ca, pf=0x4, revision=0x107
[    0.827422] microcode: Microcode Update Driver: v2.00 , Peter Oruba
[    0.834127] msgmni has been set to 3976
[    0.835057] Block layer SCSI generic (bsg) driver version 0.4 loaded (major 253)
[    0.835077] io scheduler noop registered
[    0.835086] io scheduler deadline registered
[    0.835242] io scheduler cfq registered (default)
[    0.835497] pcieport 0000:00:1c.0: irq 40 for MSI/MSI-X
[    0.835756] pcieport 0000:00:1c.0: Signaling PME through PCIe PME interrupt
[    0.835771] pci 0000:01:00.0: Signaling PME through PCIe PME interrupt
[    0.835787] pcie_pme 0000:00:1c.0:pcie01: service driver pcie_pme loaded
[    0.835836] pci_hotplug: PCI Hot Plug PCI Core version: 0.5
[    0.835916] pciehp: PCI Express Hot Plug Controller Driver version: 0.4
[    0.836501] ACPI: AC Adapter [AC] (off-line)
[    0.837069] input: Power Button as /devices/LNXSYSTM:00/device:00/PNP0C0C:00/input/input0
[    0.837093] ACPI: Power Button [PWRB]
[    0.837244] input: Sleep Button as /devices/LNXSYSTM:00/device:00/PNP0C0E:00/input/input1
[    0.837263] ACPI: Sleep Button [SLPB]
[    0.837417] input: Lid Switch as /devices/LNXSYSTM:00/device:00/PNP0C0D:00/input/input2
[    0.837897] ACPI: Lid Switch [LID]
[    0.838118] input: Power Button as /devices/LNXSYSTM:00/LNXPWRBN:00/input/input3
[    0.838137] ACPI: Power Button [PWRF]
[    0.838655] ACPI: Fan [FAN0] (off)
[    0.839282] ACPI: Fan [FAN1] (off)
[    0.839924] ACPI: Fan [FAN2] (off)
[    0.840548] ACPI: Fan [FAN3] (off)
[    0.841182] ACPI: Fan [FAN4] (off)
[    0.841361] ACPI: Requesting acpi_cpufreq
[    0.846042] Marking TSC unstable due to TSC halts in idle
[    0.846072] ACPI: acpi_idle registered with cpuidle
[    0.855642] thermal LNXTHERM:00: registered as thermal_zone0
[    0.855659] ACPI: Thermal Zone [THRM] (6 C)
[    0.856589] Non-volatile memory driver v1.3
[    0.856750] Linux agpgart interface v0.103
[    0.856909] agpgart-intel 0000:00:00.0: Intel GMA3150 Chipset
[    0.857301] agpgart-intel 0000:00:00.0: detected gtt size: 524288K total, 262144K mappable
[    0.857619] agpgart-intel 0000:00:00.0: detected 8192K stolen memory
[    0.858077] agpgart-intel 0000:00:00.0: AGP aperture is 256M @ 0x80000000
[    0.858555] tpm_tis tpm_tis: 1.2 TPM (device-id 0xB, rev-id 16)
[    0.875193] ACPI: Battery Slot [BAT0] (battery present)
[    0.991187] [drm] Initialized drm 1.1.0 20060810
[    0.991955] i915 0000:00:02.0: setting latency timer to 64
[    1.075648] i915 0000:00:02.0: irq 41 for MSI/MSI-X
[    1.075674] [drm] Supports vblank timestamp caching Rev 1 (10.10.2010).
[    1.075688] [drm] Driver supports precise vblank timestamp query.
[    1.348853] [drm] initialized overlay support
[    1.369753] fbcon: inteldrmfb (fb0) is primary device
[    1.831399] Console: switching to colour frame buffer device 160x50
[    1.842900] fb0: inteldrmfb frame buffer device
[    1.842904] drm: registered panic notifier
[    1.850468] acpi device:1b: registered as cooling_device7
[    1.851044] input: Video Bus as /devices/LNXSYSTM:00/device:00/PNP0A08:00/LNXVIDEO:00/input/input4
[    1.851216] ACPI: Video Device [OVGA] (multi-head: yes  rom: no  post: no)
[    1.851378] [drm] Initialized i915 1.6.0 20080730 for 0000:00:02.0 on minor 0
[    1.853714] loop: module loaded
[    1.853924] ahci 0000:00:1f.2: version 3.0
[    1.854061] ahci 0000:00:1f.2: irq 42 for MSI/MSI-X
[    1.854139] ahci: SSS flag set, parallel bus scan disabled
[    1.854284] ahci 0000:00:1f.2: AHCI 0001.0100 32 slots 4 ports 3 Gbps 0x1 impl SATA mode
[    1.854433] ahci 0000:00:1f.2: flags: 64bit ncq stag pm led clo pio slum part 
[    1.854567] ahci 0000:00:1f.2: setting latency timer to 64
[    1.855719] scsi0 : ahci
[    1.855997] scsi1 : ahci
[    1.856280] scsi2 : ahci
[    1.856530] scsi3 : ahci
[    1.857115] ata1: SATA max UDMA/133 abar m1024@0x92204000 port 0x92204100 irq 42
[    1.857252] ata2: DUMMY
[    1.857303] ata3: DUMMY
[    1.857353] ata4: DUMMY
[    1.857756] hso: /build/x86-mario/tmp/portage/sys-kernel/chromeos-kernel-3.4-r996/work/chromeos-kernel-3.4/drivers/net/usb/hso.c: Option Wireless
[    1.858065] usbcore: registered new interface driver hso
[    1.858328] ehci_hcd: USB 2.0 'Enhanced' Host Controller (EHCI) Driver
[    1.858528] ehci_hcd 0000:00:1d.7: setting latency timer to 64
[    1.858537] ehci_hcd 0000:00:1d.7: EHCI Host Controller
[    1.858805] ehci_hcd 0000:00:1d.7: new USB bus registered, assigned bus number 1
[    1.858989] ehci_hcd 0000:00:1d.7: using broken periodic workaround
[    1.859153] ehci_hcd 0000:00:1d.7: debug port 1
[    1.866594] ehci_hcd 0000:00:1d.7: cache line size of 64 is not supported
[    1.866642] ehci_hcd 0000:00:1d.7: irq 16, io mem 0x92204400
[    1.876068] ehci_hcd 0000:00:1d.7: USB 2.0 started, EHCI 1.00
[    1.879807] usb usb1: New USB device found, idVendor=1d6b, idProduct=0002
[    1.883542] usb usb1: New USB device strings: Mfr=3, Product=2, SerialNumber=1
[    1.887324] usb usb1: Product: EHCI Host Controller
[    1.891157] usb usb1: Manufacturer: Linux 3.4.0 ehci_hcd
[    1.894999] usb usb1: SerialNumber: 0000:00:1d.7
[    1.899149] hub 1-0:1.0: USB hub found
[    1.902963] hub 1-0:1.0: 8 ports detected
[    1.906939] ohci_hcd: USB 1.1 'Open' Host Controller (OHCI) Driver
[    1.910809] uhci_hcd: USB Universal Host Controller Interface driver
[    1.914718] uhci_hcd 0000:00:1d.0: setting latency timer to 64
[    1.914727] uhci_hcd 0000:00:1d.0: UHCI Host Controller
[    1.918737] uhci_hcd 0000:00:1d.0: new USB bus registered, assigned bus number 2
[    1.922662] uhci_hcd 0000:00:1d.0: irq 16, io base 0x00002080
[    1.926550] usb usb2: New USB device found, idVendor=1d6b, idProduct=0001
[    1.930373] usb usb2: New USB device strings: Mfr=3, Product=2, SerialNumber=1
[    1.934210] usb usb2: Product: UHCI Host Controller
[    1.937991] usb usb2: Manufacturer: Linux 3.4.0 uhci_hcd
[    1.941770] usb usb2: SerialNumber: 0000:00:1d.0
[    1.945786] hub 2-0:1.0: USB hub found
[    1.949525] hub 2-0:1.0: 2 ports detected
[    1.953387] uhci_hcd 0000:00:1d.1: setting latency timer to 64
[    1.953397] uhci_hcd 0000:00:1d.1: UHCI Host Controller
[    1.957235] uhci_hcd 0000:00:1d.1: new USB bus registered, assigned bus number 3
[    1.961044] uhci_hcd 0000:00:1d.1: irq 17, io base 0x00002060
[    1.964807] usb usb3: New USB device found, idVendor=1d6b, idProduct=0001
[    1.968497] usb usb3: New USB device strings: Mfr=3, Product=2, SerialNumber=1
[    1.972238] usb usb3: Product: UHCI Host Controller
[    1.972282] ata1: SATA link up 3.0 Gbps (SStatus 123 SControl 300)
[    1.973134] ata1.00: ACPI cmd ef/10:03:00:00:00:a0 (SET FEATURES) filtered out
[    1.983340] usb usb3: Manufacturer: Linux 3.4.0 uhci_hcd
[    1.983352] ata1.00: ATA-8: SanDisk SSD P4 16GB, SSD 8.00, max UDMA/133
[    1.983362] ata1.00: 31277232 sectors, multi 1: LBA48 
[    1.994182] usb usb3: SerialNumber: 0000:00:1d.1
[    1.994571] ata1.00: ACPI cmd ef/10:03:00:00:00:a0 (SET FEATURES) filtered out
[    1.994658] ata1.00: configured for UDMA/133
[    1.994984] scsi 0:0:0:0: Direct-Access     ATA      SanDisk SSD P4 1 SSD  PQ: 0 ANSI: 5
[    1.995675] sd 0:0:0:0: [sda] 31277232 512-byte logical blocks: (16.0 GB/14.9 Gicool smiley
[    1.995910] sd 0:0:0:0: [sda] Write Protect is off
[    1.995920] sd 0:0:0:0: [sda] Mode Sense: 00 3a 00 00
[    1.996042] sd 0:0:0:0: [sda] Write cache: enabled, read cache: enabled, doesn't support DPO or FUA
[    2.021247] hub 3-0:1.0: USB hub found
[    2.025180] hub 3-0:1.0: 2 ports detected
[    2.029346] uhci_hcd 0000:00:1d.2: setting latency timer to 64
[    2.029355] uhci_hcd 0000:00:1d.2: UHCI Host Controller
[    2.033542] uhci_hcd 0000:00:1d.2: new USB bus registered, assigned bus number 4
[    2.037564] uhci_hcd 0000:00:1d.2: irq 18, io base 0x00002040
[    2.037852]  sda: sda1 sda2 sda3 sda4 sda5 sda6 sda7 sda8 sda9 sda10 sda11 sda12
[    2.040194] sd 0:0:0:0: [sda] Attached SCSI disk
[    2.049503] usb usb4: New USB device found, idVendor=1d6b, idProduct=0001
[    2.053313] usb usb4: New USB device strings: Mfr=3, Product=2, SerialNumber=1
[    2.057121] usb usb4: Product: UHCI Host Controller
[    2.060918] usb usb4: Manufacturer: Linux 3.4.0 uhci_hcd
[    2.064742] usb usb4: SerialNumber: 0000:00:1d.2
[    2.068875] hub 4-0:1.0: USB hub found
[    2.072671] hub 4-0:1.0: 2 ports detected
[    2.076595] uhci_hcd 0000:00:1d.3: setting latency timer to 64
[    2.076605] uhci_hcd 0000:00:1d.3: UHCI Host Controller
[    2.080491] uhci_hcd 0000:00:1d.3: new USB bus registered, assigned bus number 5
[    2.084349] uhci_hcd 0000:00:1d.3: irq 19, io base 0x00002020
[    2.088198] usb usb5: New USB device found, idVendor=1d6b, idProduct=0001
[    2.092021] usb usb5: New USB device strings: Mfr=3, Product=2, SerialNumber=1
[    2.095871] usb usb5: Product: UHCI Host Controller
[    2.099682] usb usb5: Manufacturer: Linux 3.4.0 uhci_hcd
[    2.103487] usb usb5: SerialNumber: 0000:00:1d.3
[    2.107539] hub 5-0:1.0: USB hub found
[    2.111332] hub 5-0:1.0: 2 ports detected
[    2.115304] usbcore: registered new interface driver cdc_acm
[    2.119056] cdc_acm: USB Abstract Control Model driver for USB modems and ISDN adapters
[    2.123108] Initializing USB Mass Storage driver...
[    2.126971] usbcore: registered new interface driver usb-storage
[    2.130812] USB Mass Storage support registered.
[    2.134719] usbcore: registered new interface driver libusual
[    2.138613] usbcore: registered new interface driver ums-realtek
[    2.142544] usbcore: registered new interface driver usbserial
[    2.146386] usbcore: registered new interface driver usbserial_generic
[    2.150186] USB Serial support registered for generic
[    2.222085] usb 1-2: new high-speed USB device number 2 using ehci_hcd
[    2.341929] usb 1-2: config 1 has an invalid interface number: 1 but max is 0
[    2.345817] usb 1-2: config 1 has no interface number 0
[    2.351426] usb 1-2: New USB device found, idVendor=1410, idProduct=a014
[    2.355266] usb 1-2: New USB device strings: Mfr=3, Product=2, SerialNumber=0
[    2.359054] usb 1-2: Product: Gobi 2000
[    2.362765] usb 1-2: Manufacturer: Qualcomm Incorporated
[    2.470073] usb 1-5: new high-speed USB device number 3 using ehci_hcd
[    2.813914] usb 1-5: New USB device found, idVendor=04f2, idProduct=b205
[    2.817664] usb 1-5: New USB device strings: Mfr=2, Product=1, SerialNumber=0
[    2.821386] usb 1-5: Product: Mario Webcam
[    2.825058] usb 1-5: Manufacturer: Chicony Electronics Co., Ltd.
[    3.035210] usbserial: USB Serial Driver core
[    3.038942] i8042: PNP: PS/2 Controller [PNP0303:KBC,PNP0f13:MOUE] at 0x60,0x64 irq 1,12
[    3.046909] i8042: Detected active multiplexing controller, rev 1.1
[    3.053443] serio: i8042 KBD port at 0x60,0x64 irq 1
[    3.057081] serio: i8042 AUX0 port at 0x60,0x64 irq 12
[    3.060809] serio: i8042 AUX1 port at 0x60,0x64 irq 12
[    3.064460] serio: i8042 AUX2 port at 0x60,0x64 irq 12
[    3.068053] serio: i8042 AUX3 port at 0x60,0x64 irq 12
[    3.071780] mousedev: PS/2 mouse device common for all mice
[    3.076327] coretemp coretemp.0: Using relative temperature scale!
[    3.080111] device-mapper: ioctl: 4.22.0-ioctl (2011-10-19) initialised: dm-devel@redhat.com
[    3.083699] device-mapper: verity: version 0.1.0 loaded
[    3.087219] device-mapper: verity-chromeos: dm-verity-chromeos registered
[    3.090880] cpuidle: using governor ladder
[    3.094571] cpuidle: using governor menu
[    3.098205] usbcore: registered new interface driver usbhid
[    3.101719] usbhid: USB HID core driver
[    3.106544] Netfilter messages via NETLINK v0.30.
[    3.110120] nf_conntrack version 0.5.0 (16384 buckets, 65536 max)
[    3.113964] input: AT Translated Set 2 keyboard as /devices/platform/i8042/serio0/input/input5
[    3.114065] ctnetlink v0.93: registering with nfnetlink.
[    3.114413] ip_tables: (C) 2000-2006 Netfilter Core Team
[    3.114522] TCP: cubic registered
[    3.114527] Initializing XFRM netlink socket
[    3.115120] NET: Registered protocol family 10
[    3.115852] NET: Registered protocol family 17
[    3.140476]   Magic number: 0:323:997
[    3.145248] ALSA device list:
[    3.148763]   No soundcards found.
[    3.152697] EXT3-fs (sda7): error: couldn't mount because of unsupported optional features (240)
[    3.169548] EXT2-fs (sda7): error: couldn't mount because of unsupported optional features (240)
[    3.190828] EXT4-fs (sda7): mounted filesystem with ordered data mode. Opts: (null)
[    3.196687] VFS: Mounted root (ext4 filesystem) readonly on device 8:7.
[    3.201896] devtmpfs: mounted
[    3.209980] Freeing unused kernel memory: 624k freed
[    3.213879] Write protecting the kernel read-only data: 8192k
[    3.236162] Freeing unused kernel memory: 1652k freed
[    3.244264] Freeing unused kernel memory: 264k freed
[    3.268129] usb 4-2: new full-speed USB device number 2 using uhci_hcd
[    3.393277] init: Failed to create pty - disabling logging for job
[    3.399624] init: Temporary process spawn error: No space left on device
[    3.419767] init: Failed to create pty - disabling logging for job
[    3.424620] init: Temporary process spawn error: No space left on device
[    3.431864] init: Failed to create pty - disabling logging for job
[    3.436133] init: Temporary process spawn error: No space left on device
[    3.442871] init: Failed to create pty - disabling logging for job
[    3.446818] init: Temporary process spawn error: No space left on device
[    3.458532] usb 4-2: New USB device found, idVendor=0403, idProduct=6001
[    3.462545] usb 4-2: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[    3.466437] usb 4-2: Product: FT232R USB UART
[    3.470927] usb 4-2: Manufacturer: FTDI
[    3.474658] usb 4-2: SerialNumber: A101KYFH
[    3.613944] init: Failed to create pty - disabling logging for job
[    3.618556] init: Temporary process spawn error: No space left on device
[    3.634129] init: Failed to create pty - disabling logging for job
[    3.637991] init: Temporary process spawn error: No space left on device
[    3.660281] init: Failed to create pty - disabling logging for job
[    3.664311] init: Temporary process spawn error: No space left on device
[    3.693096] usb 5-2: new full-speed USB device number 2 using uhci_hcd
[    3.840242] usb 5-2: New USB device found, idVendor=0cf3, idProduct=3005
[    3.845417] usb 5-2: New USB device strings: Mfr=0, Product=0, SerialNumber=0
[    3.917383] udevd[148]: starting version 175
[    4.166208] psmouse serio4: synaptics: Touchpad model: 1, fw: 7.5, id: 0x1e0b1, caps: 0xd00073/0x640000/0x5a0400, board id: 1382, fw id: 705157
[    4.207286] input: SynPS/2 Synaptics TouchPad as /devices/platform/i8042/serio4/input/input6
[    4.269523] init: plymouth main process (61) killed by SEGV signal
[    4.270318] init: plymouth-splash main process (198) terminated with status 2
[    4.399323] snd_hda_intel 0000:00:1b.0: irq 43 for MSI/MSI-X
[    4.474122] rtc_cmos 00:03: RTC can wake from S4
[    4.480302] rtc_cmos 00:03: rtc core: registered rtc_cmos as rtc0
[    4.480368] rtc0: alarms up to one month, 242 bytes nvram, hpet irqs
[    4.489164] cfg80211: Calling CRDA to update world regulatory domain
[    4.526901] input: HDA Intel Mic as /devices/pci0000:00/0000:00:1b.0/sound/card0/input7
[    4.528932] input: HDA Intel Headphone as /devices/pci0000:00/0000:00:1b.0/sound/card0/input8
[    4.665098] industrialio: module is from the staging directory, the quality is unknown, you have been warned.
[    4.666410] tsl2563: module is from the staging directory, the quality is unknown, you have been warned.
[    4.697318] Bluetooth: Core ver 2.16
[    4.697487] NET: Registered protocol family 31
[    4.697494] Bluetooth: HCI device and connection manager initialized
[    4.697503] Bluetooth: HCI socket layer initialized
[    4.697509] Bluetooth: L2CAP socket layer initialized
[    4.697527] Bluetooth: SCO socket layer initialized
[    4.714101] tsl2563 6-0029: model 4, rev. 0
[    4.715526] usbcore: registered new interface driver btusb
[    4.826426] usbcore: registered new interface driver qcserial
[    4.826550] USB Serial support registered for Qualcomm USB modem
[    4.826604] qcserial 1-2:1.1: Qualcomm USB modem converter detected
[    4.827065] usb 1-2: Qualcomm USB modem converter now attached to ttyUSB0
[    4.868924] Linux video capture interface: v2.00
[    4.903854] uvcvideo: Found UVC 1.00 device Mario Webcam (04f2:b205)
[    4.929978] usbcore: registered new interface driver uvcvideo
[    4.929984] USB Video Class driver (1.1.1)
[    5.035196] ath: phy0: ASPM enabled: 0x42
[    5.035209] ath: EEPROM regdomain: 0x60
[    5.035216] ath: EEPROM indicates we should expect a direct regpair map
[    5.035226] ath: Country alpha2 being used: 00
[    5.035233] ath: Regpair used: 0x60
[    5.051833] nm10_gpio version 0.04 built on Aug 26 2012 at 19:06:30
[    5.051861] gpiochip_find_base: found new base at 192
[    5.051989] gpiochip_add: registered GPIOs 192 to 255 on device: 0000:00:1f.0
[    5.103430] ieee80211 phy0: Selected rate control algorithm 'ath9k_rate_control'
[    5.105899] Registered led device: ath9k-phy0
[    5.105923] ieee80211 phy0: Atheros AR9280 Rev:2 mem=0xffffc900004a0000, irq=16
[    5.513653] cfg80211: World regulatory domain updated:
[    5.513665] cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
[    5.513676] cfg80211:   (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[    5.513687] cfg80211:   (2457000 KHz - 2482000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
[    5.513697] cfg80211:   (2474000 KHz - 2494000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
[    5.513708] cfg80211:   (5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[    5.513718] cfg80211:   (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[    6.026171] EXT4-fs (sda7): re-mounted. Opts: errors=remount-ro
[    6.347264] init: plymouth-log main process (539) terminated with status 1
[    6.397600] init: failsafe main process (543) killed by TERM signal
[    6.556540] init: plymouth-upstart-bridge main process (581) terminated with status 1
[    6.666301] Bluetooth: RFCOMM socket layer initialized
[    6.666310] Bluetooth: RFCOMM ver 1.11
[    7.123287] ieee80211 phy0: device now idle
[    7.138874] ADDRCONF(NETDEV_UP): wlan0: link is not ready
[    7.338342] ieee80211 phy0: device no longer idle - scanning
[    7.714840] init: anacron main process (660) killed by TERM signal
[    9.551205] fuse init (API version 7.18)
[   12.410868] ieee80211 phy0: device now idle
[   12.453944] ieee80211 phy0: device no longer idle - scanning
[   16.733955] wlan0: authenticate with 00:25:9c:34:7d:d2
[   16.733992] ieee80211 phy0: Allocated STA 00:25:9c:34:7d:d2
[   16.751555] ieee80211 phy0: Inserted STA 00:25:9c:34:7d:d2
[   16.751570] wlan0: send auth to 00:25:9c:34:7d:d2 (try 1/3)
[   16.754797] wlan0: authenticated
[   16.754811] wlan0: moving STA 00:25:9c:34:7d:d2 to state 2
[   16.764084] wlan0: associate with 00:25:9c:34:7d:d2 (try 1/3)
[   16.768501] wlan0: RX AssocResp from 00:25:9c:34:7d:d2 (capab=0x411 status=0 aid=5)
[   16.768514] wlan0: associated
[   16.768590] wlan0: moving STA 00:25:9c:34:7d:d2 to state 3
[   16.768613] ieee80211 phy0: WMM queue=2 aci=0 acm=0 aifs=3 cWmin=15 cWmax=1023 txop=0 uapsd=0
[   16.768635] ieee80211 phy0: WMM queue=3 aci=1 acm=0 aifs=7 cWmin=15 cWmax=1023 txop=0 uapsd=0
[   16.768654] ieee80211 phy0: WMM queue=1 aci=2 acm=0 aifs=2 cWmin=7 cWmax=15 txop=94 uapsd=0
[   16.768671] ieee80211 phy0: WMM queue=0 aci=3 acm=0 aifs=2 cWmin=3 cWmax=7 txop=47 uapsd=0
[   16.779089] ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
[   16.781097] wlan0: dropped frame to 00:25:9c:34:7d:d2 (unauthorized port)
[   16.781521] wlan0: moving STA 00:25:9c:34:7d:d2 to state 4
[   42.704076] wlan0: detected beacon loss from AP - sending probe request
[   42.724553] wlan0: cancelling probereq poll due to a received beacon
[   54.708089] wlan0: detected beacon loss from AP - sending probe request
[   54.805562] wlan0: cancelling probereq poll due to a received beacon
[   58.712145] wlan0: detected beacon loss from AP - sending probe request
[   58.799309] wlan0: cancelling probereq poll due to a received beacon
[   60.708134] wlan0: detected beacon loss from AP - sending probe request
[   60.744985] wlan0: cancelling probereq poll due to a received beacon
[   62.708133] wlan0: detected beacon loss from AP - sending probe request
[   62.793161] wlan0: cancelling probereq poll due to a received beacon
[   64.704099] wlan0: detected beacon loss from AP - sending probe request
[   64.841181] wlan0: cancelling probereq poll due to a received beacon
[   66.708142] wlan0: detected beacon loss from AP - sending probe request
[   66.786848] wlan0: cancelling probereq poll due to a received beacon
[   80.616315] ath: phy0: unsupported hw bitrate detected 0x1b using 1 Mbit
[   84.712059] wlan0: detected beacon loss from AP - sending probe request
[   84.912212] wlan0: cancelling probereq poll due to a received beacon
[   89.712217] wlan0: detected beacon loss from AP - sending probe request
[   89.827590] wlan0: cancelling probereq poll due to a received beacon
[   91.708074] wlan0: detected beacon loss from AP - sending probe request
[   91.773286] wlan0: cancelling probereq poll due to a received beacon
[   98.712103] wlan0: detected beacon loss from AP - sending probe request
[   98.736725] wlan0: cancelling probereq poll due to a received beacon
[  101.712100] wlan0: detected beacon loss from AP - sending probe request
[  101.808839] wlan0: cancelling probereq poll due to a received beacon
[  103.708075] wlan0: detected beacon loss from AP - sending probe request
[  103.754501] wlan0: cancelling probereq poll due to a received beacon
[  107.708091] wlan0: detected beacon loss from AP - sending probe request
[  107.748274] wlan0: cancelling probereq poll due to a received beacon
[  109.708111] wlan0: detected beacon loss from AP - sending probe request
[  109.796336] wlan0: cancelling probereq poll due to a received beacon
[  111.704113] wlan0: detected beacon loss from AP - sending probe request
[  111.741975] wlan0: cancelling probereq poll due to a received beacon
[  113.708082] wlan0: detected beacon loss from AP - sending probe request
[  113.790292] wlan0: cancelling probereq poll due to a received beacon
[  115.704156] wlan0: detected beacon loss from AP - sending probe request
[  115.735756] wlan0: cancelling probereq poll due to a received beacon
[  117.708101] wlan0: detected beacon loss from AP - sending probe request
[  117.783877] wlan0: cancelling probereq poll due to a received beacon
[  119.708117] wlan0: detected beacon loss from AP - sending probe request
[  119.729534] wlan0: cancelling probereq poll due to a received beacon
[  121.708139] wlan0: detected beacon loss from AP - sending probe request
[  121.777555] wlan0: cancelling probereq poll due to a received beacon
[  123.708128] wlan0: detected beacon loss from AP - sending probe request
[  123.723278] wlan0: cancelling probereq poll due to a received beacon
[  125.708139] wlan0: detected beacon loss from AP - sending probe request
[  125.771311] wlan0: cancelling probereq poll due to a received beacon
[  127.708066] wlan0: detected beacon loss from AP - sending probe request
[  127.716921] wlan0: cancelling probereq poll due to a received beacon
user@ChrUbuntu:~$ 
Sorry, only registered users may post in this forum.

Click here to login