Welcome! Log In Create A New Profile

Advanced

Stepper Motor turns one direction only

Posted by ostrich99 
Stepper Motor turns one direction only
November 18, 2011 02:26PM
All,

So I have my RAMPS 1.4 up and running with Sprinter and Pronterface and I'm trying to test if my stepper motor wiring is correct.

When I start Pronterface and connect to my RAMPS, the motor I have connected for testing moves in the postive direction, but doesn't move at all in the negative direction. I have this setup in the Z Axis connector for now, but have also tried it on the Y axis.

I did some wire swapping per the wiki entry for Stepper Motors on here, but still can't get them to turn both ways.

Any suggestions?
Re: Stepper Motor turns one direction only
November 18, 2011 02:32PM
I don't need endstops plugged in do I for testing the motors?
Re: Stepper Motor turns one direction only
November 18, 2011 02:36PM
If you want to test the motors without endstops attached, you need to disable endstops in firmware. The bot doesn't know if you have them connected or not, and interprets no endstop the same as triggered endstop, to be on the safe side.


--
-Nudel
Blog with RepRap Comic
Re: Stepper Motor turns one direction only
November 18, 2011 04:59PM
Since there didn't seem to be an obvious way to turn the endstops off in the firmware config (I'm using sprinter) I just plugged the motor in the extruder stepper motor and it's moving both ways now.

I found some stuff regarding min/max endstops and messed with those settings, but then figured out I could just use the extruder headers to see if I have the motors wired up right.

Guess I'll go ahead and put the connectors on the other motors now.

Any suggestions on if I should use the double headers on the RAMPS board for the Z axis or run one of the motors over to a block on the other motor like I've seen in some builder videos?

Thanks for all the help. This is quite a different beast than my MakerBot because of all of the other choices for each of the components.
Re: Stepper Motor turns one direction only
July 05, 2013 09:13AM
I'm having the same problem here, everything is working aside from the extruder stepper, it turns only in one direction weather I tell it to extrude or reverse. Switching the z axis motor allows me to:
-move the extruder-stepper backwards and forwards using the controls for the Z axis
-move the z-stepper in one direction only using the extrude/reverse controls
This problems presents both in marlin and in repetier- I'm so close to a first print I can taste it!

I'm worried that the problem is with the stepper driver as I'm using a printrboard so an electrical fault with any one stepper necessitates replacement the whole board (or retrofitting a pololu on some spare headers, if that's even possible)
Sorry, only registered users may post in this forum.

Click here to login