Welcome! Log In Create A New Profile

Advanced

Huxley

http://reprap.org/wiki/Huxley Huxley is like Mendel, only smaller and cuter. 
Subject Views Posts Last Post

Colour touch screen control panel for Huxley Duo

by dc42
2,059 1 03/27/2015 03:02AM
Last Post by dc42

Need Help! Attachments

by needhelp101
2,038 9 03/20/2015 12:55PM
Last Post by 3Dmaker4U

Huxley duo wiring loom

by pd62
1,993 3 03/10/2015 01:50PM
Last Post by pd62

Got troubles with my Huxley He3d hot end

by smartwong
2,061 2 03/10/2015 12:51AM
Last Post by csambrook

Settings to print new parts

by jmknox
2,118 3 02/14/2015 02:04PM
Last Post by jmknox

Cooling Fan on a Melzi Board

by adilmalik
1,516 3 02/03/2015 12:29PM
Last Post by Jokek

Unsure how to secure belt overlap in belt clamp

by KennethY89
2,390 5 01/16/2015 09:39PM
Last Post by KennethY89

Huxley Duo - Cooling fan - NOT hothead fan

by jmknox
2,459 7 01/09/2015 03:53AM
Last Post by droftarts

Problems with Z-axis moving in one direction, pls help!!

by Durac3ll
2,374 4 01/04/2015 06:40AM
Last Post by Durac3ll

Huxley Melzi firmware problem

by RobertEdwards
1,913 8 01/04/2015 03:09AM
Last Post by peter_xm

Y axis jittering on first layer Attachments

by ThePhilStrongProject
2,131 2 12/22/2014 12:57PM
Last Post by 3Dmaker4U

Help a non-techie with 4 issues with his Huxley

by KennethY89
2,206 4 11/26/2014 11:40AM
Last Post by 3Dmaker4U

Huxley - Ubuntu USB driver issue

by 3d@thegallery
2,540 6 11/03/2014 11:16AM
Last Post by 3d@thegallery

Bringing my Huxley back to life

by rupert
2,188 5 10/29/2014 03:05AM
Last Post by rupert

Fried Zaxis stepper motor driver

by RobertEdwards
2,026 3 10/07/2014 06:50PM
Last Post by RobertEdwards

Huxley Dual Head Mod

by rainingheavy
2,144 10 09/27/2014 09:39AM
Last Post by rainingheavy

Heatbed does not heat

by MattMiller
3,083 13 09/26/2014 08:23PM
Last Post by BenZ

Lasercut Frog

by Dave84
1,824 3 09/23/2014 10:11AM
Last Post by Dave84

Heatbed won't turn off

by villainous
2,458 7 08/27/2014 09:15PM
Last Post by 3Dmaker4U

Thanks everyone! Attachments

by KD0SKH
712 3 08/24/2014 06:34AM
Last Post by Phuzzy Logic

Huxley control board

by Sean Eldridge
2,808 3 08/07/2014 01:35AM
Last Post by Traumflug

Huxley heatbed connect to Ramps 1.4

by rainingheavy
1,849 8 08/01/2014 11:10AM
Last Post by rainingheavy

Rescue a stalled build!!!

by timmy
904 6 07/22/2014 11:27PM
Last Post by timmy

Fried chip when i connected power the first time.

by ghazz
1,455 7 07/18/2014 12:19PM
Last Post by 3Dmaker4U

Too much filament

by topias5
1,133 2 07/13/2014 05:06AM
Last Post by 3Dmaker4U

Adding a Fan

by PatrickT
893 4 07/07/2014 06:48AM
Last Post by PatrickT

Print quality degrading after ~15 layers

by ThePhilStrongProject
956 5 07/01/2014 06:52AM
Last Post by ThePhilStrongProject

Upgrading firmware to later/latest Marlin

by epatel
714 8 06/11/2014 08:33AM
Last Post by alvin

can someone help me with my printer Attachments

by Reece
835 3 05/30/2014 10:14PM
Last Post by sarazhang

Fan stops when I start print

by Harvey
1,047 5 05/29/2014 04:06AM
Last Post by droftarts